summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-12 13:00:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-12 14:24:28 +0000
commit880a404a6daca5e4b606bab8d0b67dd581dd242c (patch)
tree77315dc7357f6f2116380ba766c2e2e64363538e /main
parent76a32b96eb1fdb398317bbb8c05755415a28da4b (diff)
downloadaports-880a404a6daca5e4b606bab8d0b67dd581dd242c.tar.bz2
aports-880a404a6daca5e4b606bab8d0b67dd581dd242c.tar.xz
main/openrc: localmount: don't umount .modloop
fixes #178 (cherry picked from commit 52e59e902232fa150e2e8ced9e66bbd5d4140023)
Diffstat (limited to 'main')
-rw-r--r--main/openrc/APKBUILD4
-rw-r--r--main/openrc/localmount.patch12
2 files changed, 15 insertions, 1 deletions
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index a6fab9a3..5e156966 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openrc
pkgver=0.5.0
-pkgrel=11
+pkgrel=12
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="http://roy.marples.name/openrc"
license='BSD-2'
@@ -13,6 +13,7 @@ source="http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.bz2
command-line-size-fix.patch
openrc-0.4.3-mkmntdirs.patch
openrc-hwclock.patch
+ localmount.patch
hostname.initd
hwdrivers.initd
keymaps.initd
@@ -51,6 +52,7 @@ md5sums="9ec7f8425e12abbbd0f7a962aae3fa3c openrc-0.5.0.tar.bz2
396b1cbd399403ba0448402afc6f9220 command-line-size-fix.patch
8c2c1c2ee0509b63966b7187a2079f4b openrc-0.4.3-mkmntdirs.patch
f462c976b04cfbb35b2335be15eee7f6 openrc-hwclock.patch
+fa1809cd59cc0559a163bc6adc7398f6 localmount.patch
c32e15b0858eef708497e7ee6355a055 hostname.initd
b1e64885f301166df30be3e3cf5338ff hwdrivers.initd
33ca3e558c42cdd17adccbc7807298f7 keymaps.initd
diff --git a/main/openrc/localmount.patch b/main/openrc/localmount.patch
new file mode 100644
index 00000000..c80d640a
--- /dev/null
+++ b/main/openrc/localmount.patch
@@ -0,0 +1,12 @@
+diff -ru openrc-0.5.0.orig/init.d/localmount.in openrc-0.5.0/init.d/localmount.in
+--- openrc-0.5.0.orig/init.d/localmount.in 2009-10-09 09:08:43.000000000 +0000
++++ openrc-0.5.0/init.d/localmount.in 2009-10-09 09:09:08.000000000 +0000
+@@ -31,7 +31,7 @@
+ {
+ # We never unmount / or /dev or $RC_SVCDIR
+ local x= no_umounts_r="/|/dev|/dev/.*|${RC_SVCDIR}"
+- no_umounts_r="${no_umounts_r}|/bin|/sbin|/lib|/libexec"
++ no_umounts_r="${no_umounts_r}|/bin|/sbin|/lib|/libexec|/.modloop"
+ # RC_NO_UMOUNTS is an env var that can be set by plugins
+ OIFS=$IFS SIFS=${IFS-y}
+ IFS=$IFS: