summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-09 09:30:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-09 09:58:37 +0000
commitc3c01e5e5839837e0dccca120ad30de28b1c421f (patch)
treea13e9a81cad4972b4cd641b96431849f9ca3b24c /main
parent38739dd16fb930bcc9b95cc54f263e570457b384 (diff)
downloadaports-c3c01e5e5839837e0dccca120ad30de28b1c421f.tar.bz2
aports-c3c01e5e5839837e0dccca120ad30de28b1c421f.tar.xz
main/imap: avoid text relocations by adding -fPIC
This fixes #202 (cherry picked from commit 1de0884b00ee386c313845cddc0163d6685c8cc2)
Diffstat (limited to 'main')
-rw-r--r--main/imap/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/imap/APKBUILD b/main/imap/APKBUILD
index d8dd4fe8..14c1ac72 100644
--- a/main/imap/APKBUILD
+++ b/main/imap/APKBUILD
@@ -5,7 +5,7 @@
# build it shared
pkgname=imap
pkgver=2007e
-pkgrel=0
+pkgrel=1
pkgdesc="An IMAP/POP server"
url="http://www.washington.edu/imap"
license="APACHE"
@@ -24,7 +24,8 @@ build ()
-i src/osdep/unix/Makefile || return 1
export GCCCFLAGS="$CFLAGS"
- make slx SPECIALAUTHENTICATORS=ssl || return 1
+ make slx SPECIALAUTHENTICATORS=ssl EXTRACFLAGS="$CFLAGS -fPIC" \
+ || return 1
mkdir -p $pkgdir/usr/sbin
install -D -m755 imapd/imapd $pkgdir/usr/sbin/imapd