summaryrefslogtreecommitdiffstats
path: root/testing/bacula-client/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-03 07:41:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-03 07:41:11 +0000
commit09ce0508afe6568cf580f53fb9952963125fff43 (patch)
treebe336c26f16f7fd1e5c5454738c9332da34fb2d1 /testing/bacula-client/APKBUILD
parent9ad548df8aa2a860ca311453ed3d6a98962f32f5 (diff)
downloadaports-09ce0508afe6568cf580f53fb9952963125fff43.tar.bz2
aports-09ce0508afe6568cf580f53fb9952963125fff43.tar.xz
Revert "testing/*: remove from stable branch"
This reverts commit 9ad548df8aa2a860ca311453ed3d6a98962f32f5. I'll delete them one by one.
Diffstat (limited to 'testing/bacula-client/APKBUILD')
-rw-r--r--testing/bacula-client/APKBUILD70
1 files changed, 70 insertions, 0 deletions
diff --git a/testing/bacula-client/APKBUILD b/testing/bacula-client/APKBUILD
new file mode 100644
index 00000000..3156c9dd
--- /dev/null
+++ b/testing/bacula-client/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname="bacula-client"
+_realname="bacula"
+pkgver=3.0.3
+pkgrel=0
+pkgdesc="Client (File Daemon) of Bacula, a network based backup program"
+url="http://www.bacula.org"
+license="GPL2"
+depends="openssl ncurses"
+makedepends="openssl-dev autoconf ncurses-dev"
+install="$pkgname.pre-install $pkgname.post-install"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/$_realname/$_realname/$pkgver/$_realname-$pkgver.tar.gz
+bacula-fd-init
+bacula-fd-conf
+configure.in.patch
+os.m4.patch"
+
+prepare () {
+ cd "$srcdir/$_realname-$pkgver"
+ patch -p1 < ../../configure.in.patch
+ patch -p1 < ../../os.m4.patch
+}
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+ export LDFLAGS=
+ # Need to run configure at least once
+ # in order to do not go into an infinite loop
+ ./configure
+ make configure
+ make distclean
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/bacula \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc \
+ --infodir=/usr/share/info \
+ --with-pid-dir=/var/run \
+ --with-subsys-dir=/var/lock/subsys \
+ --enable-largefile \
+ --enable-client-only \
+ --disable-nls \
+ --with-openssl=/usr/include/openssl \
+ --with-scriptdir=/etc/bacula/scripts \
+ --with-working-dir=/var/bacula \
+ --with-fd-user=root \
+ --with-fd-group=root \
+ --with-fd-password=ca4pheexie1aeC1hee3i \
+
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm755 $srcdir/bacula-fd-init \
+ $pkgdir/etc/init.d/bacula-fd
+ install -Dm644 $srcdir/bacula-fd-conf \
+ $pkgdir/etc/conf.d/bacula-fd
+}
+
+md5sums="feba58691b674b12056359d459ad6940 bacula-3.0.3.tar.gz
+38b0fe78acdc5e65aec3a59578e98a20 bacula-fd-init
+4500ce2d62bf9df33c07f70dc40f7b85 bacula-fd-conf
+ebc9c2bbc9be95c920723a3f142d8e19 configure.in.patch
+cf7a2a4e972697f54364654c4e282b8b os.m4.patch"