summaryrefslogtreecommitdiffstats
path: root/testing/device-mapper
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2009-02-26 09:38:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-26 20:15:50 +0000
commit1be5658cc4f5ac52ef0de9a6f4c96ab52d2bcde9 (patch)
treeaa1a2e59dc01c0f3d28a6a50a309376d45a17182 /testing/device-mapper
parent188ae650ad0b02f6c9e0028757c5b11c8fbce531 (diff)
downloadaports-1be5658cc4f5ac52ef0de9a6f4c96ab52d2bcde9.tar.bz2
aports-1be5658cc4f5ac52ef0de9a6f4c96ab52d2bcde9.tar.xz
testing/device-mapper: new aport
Diffstat (limited to 'testing/device-mapper')
-rw-r--r--testing/device-mapper/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/device-mapper/APKBUILD b/testing/device-mapper/APKBUILD
new file mode 100644
index 00000000..aaca6808
--- /dev/null
+++ b/testing/device-mapper/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=device-mapper
+pkgver=1.02.28
+pkgrel=0
+pkgdesc="Device mapper ioctl library"
+url="http://sources.redhat.com/pub/dm/"
+license="GPL-2"
+depends="uclibc"
+makedepends=""
+install=
+subpackages="$pkgname-doc $pkgname-dev"
+source="ftp://sources.redhat.com/pub/dm/$pkgname.$pkgver.tgz"
+
+build() {
+ cd "$srcdir/$pkgname.$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="c9ae0776994a419f9e1ba842164bb626 device-mapper.1.02.28.tgz"