summaryrefslogtreecommitdiffstats
path: root/testing/dhcpcd
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-03-18 18:46:13 +0000
committerMichael Mason <ms13sp@gmail.com>2009-03-18 18:46:13 +0000
commit8fe97ac5e09aef5f6a7ce8055241743acc8a8ee9 (patch)
tree17ff8e809c221a52e14aa30817b82710613a5989 /testing/dhcpcd
parentc746a58e0fee8f3cccc01f97f53ab20e5b733c16 (diff)
downloadaports-8fe97ac5e09aef5f6a7ce8055241743acc8a8ee9.tar.bz2
aports-8fe97ac5e09aef5f6a7ce8055241743acc8a8ee9.tar.xz
testing/dhcpcd Initial Commit
Diffstat (limited to 'testing/dhcpcd')
-rw-r--r--testing/dhcpcd/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/dhcpcd/APKBUILD b/testing/dhcpcd/APKBUILD
new file mode 100644
index 00000000..9d00eefc
--- /dev/null
+++ b/testing/dhcpcd/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer:
+pkgname=dhcpcd
+pkgver=4.0.12
+pkgrel=0
+pkgdesc="RFC2131 compliant DHCP client"
+url="http://roy.marples.name/projects/dhcpcd/"
+license="GPL"
+depends="uclibc"
+makedepends=""
+install=
+subpackages="$pkgname-doc"
+source="http://roy.marples.name/downloads/dhcpcd/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+}
+
+md5sums="595311cb85071b2f11e6ca246a20d5c7 dhcpcd-4.0.12.tar.bz2"