summaryrefslogtreecommitdiffstats
path: root/testing/hdparm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-23 09:51:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-23 09:51:50 +0000
commit431139473935bf88e01bd6632fa740bc1eb9857a (patch)
treea9bdcce9ccbb39f6aa73e7176da4ff724be68e46 /testing/hdparm
parentf85ba1c36faba0db620c454e13fd96d72dd88250 (diff)
downloadaports-431139473935bf88e01bd6632fa740bc1eb9857a.tar.bz2
aports-431139473935bf88e01bd6632fa740bc1eb9857a.tar.xz
testing/hdparm: new aport
A shell utility for manipulating Linux IDE drive/driver parameters http://sourceforge.net/projects/hdparm/
Diffstat (limited to 'testing/hdparm')
-rw-r--r--testing/hdparm/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/hdparm/APKBUILD b/testing/hdparm/APKBUILD
new file mode 100644
index 00000000..38ca77c6
--- /dev/null
+++ b/testing/hdparm/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=hdparm
+pkgver=9.27
+pkgrel=0
+pkgdesc="A shell utility for manipulating Linux IDE drive/driver parameters"
+url="http://sourceforge.net/projects/hdparm/"
+license="BSD"
+depends=
+makedepends=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr "$pkgdir"/sbin
+ make DESTDIR="$pkgdir" install || return 1
+ install -m755 contrib/idectl "$pkgdir"/sbin || return 1
+ install -m755 contrib/ultrabayd "$pkgdir"/sbin || return 1
+ install -D -m 644 LICENSE.TXT $pkgdir/usr/share/licenses/hdparm/LICENSE.TXT || return 1
+}
+md5sums="e652dabb6c9233fb8a23ef60a17a1829 hdparm-9.27.tar.gz"