summaryrefslogtreecommitdiffstats
path: root/testing/icecast
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-03 07:41:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-03 07:41:11 +0000
commit09ce0508afe6568cf580f53fb9952963125fff43 (patch)
treebe336c26f16f7fd1e5c5454738c9332da34fb2d1 /testing/icecast
parent9ad548df8aa2a860ca311453ed3d6a98962f32f5 (diff)
downloadaports-09ce0508afe6568cf580f53fb9952963125fff43.tar.bz2
aports-09ce0508afe6568cf580f53fb9952963125fff43.tar.xz
Revert "testing/*: remove from stable branch"
This reverts commit 9ad548df8aa2a860ca311453ed3d6a98962f32f5. I'll delete them one by one.
Diffstat (limited to 'testing/icecast')
-rw-r--r--testing/icecast/APKBUILD32
-rw-r--r--testing/icecast/icecast.initd18
2 files changed, 50 insertions, 0 deletions
diff --git a/testing/icecast/APKBUILD b/testing/icecast/APKBUILD
new file mode 100644
index 00000000..73135371
--- /dev/null
+++ b/testing/icecast/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor:
+# Maintainer:
+pkgname=icecast
+pkgver=2.3.2
+pkgrel=0
+pkgdesc="Open source media server"
+url="http://www.icecast.org"
+license="GPL"
+depends=
+makedepends="libxslt-dev libxml2-dev libogg-dev libvorbis-dev libtheora-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+ icecast.initd"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -D -m755 ../icecast.initd "$pkgdir"/etc/init.d/icecast
+}
+
+md5sums="ff516b3ccd2bcc31e68f460cd316093f icecast-2.3.2.tar.gz
+b6f2fc5eaada6e9389784ccf43f68684 icecast.initd"
diff --git a/testing/icecast/icecast.initd b/testing/icecast/icecast.initd
new file mode 100644
index 00000000..b82e5cdd
--- /dev/null
+++ b/testing/icecast/icecast.initd
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting Icecast 2"
+ start-stop-daemon --background --start --make-pidfile --pidfile /var/run/icecast.pid --exec /usr/bin/icecast -- -c /etc/icecast.xml
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Icecast 2"
+ start-stop-daemon --stop --pidfile /var/run/icecast.pid --name icecast
+ eend $?
+}