summaryrefslogtreecommitdiffstats
path: root/testing/icecast
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-29 14:05:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-29 14:05:15 +0000
commit4af401f41b5cd69b4b41d0640d232d0502a188ac (patch)
treea5c584cd90b2dc45754648e891340b2d1cc58af6 /testing/icecast
parent4e307f139bef6d2f63b573f59da4e3376b9259e5 (diff)
downloadaports-4af401f41b5cd69b4b41d0640d232d0502a188ac.tar.bz2
aports-4af401f41b5cd69b4b41d0640d232d0502a188ac.tar.xz
testing/icecast: added init.d script from gentoo
Diffstat (limited to 'testing/icecast')
-rw-r--r--testing/icecast/APKBUILD15
-rw-r--r--testing/icecast/icecast.initd18
2 files changed, 29 insertions, 4 deletions
diff --git a/testing/icecast/APKBUILD b/testing/icecast/APKBUILD
index b9d34f42..73135371 100644
--- a/testing/icecast/APKBUILD
+++ b/testing/icecast/APKBUILD
@@ -6,10 +6,11 @@ pkgrel=0
pkgdesc="Open source media server"
url="http://www.icecast.org"
license="GPL"
-depends="busybox"
+depends=
makedepends="libxslt-dev libxml2-dev libogg-dev libvorbis-dev libtheora-dev"
subpackages="$pkgname-doc"
-source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+ icecast.initd"
build() {
cd "$srcdir"/$pkgname-$pkgver
@@ -18,8 +19,14 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info
- make || return 1
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
+ install -D -m755 ../icecast.initd "$pkgdir"/etc/init.d/icecast
}
-md5sums="ff516b3ccd2bcc31e68f460cd316093f icecast-2.3.2.tar.gz"
+md5sums="ff516b3ccd2bcc31e68f460cd316093f icecast-2.3.2.tar.gz
+b6f2fc5eaada6e9389784ccf43f68684 icecast.initd"
diff --git a/testing/icecast/icecast.initd b/testing/icecast/icecast.initd
new file mode 100644
index 00000000..b82e5cdd
--- /dev/null
+++ b/testing/icecast/icecast.initd
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting Icecast 2"
+ start-stop-daemon --background --start --make-pidfile --pidfile /var/run/icecast.pid --exec /usr/bin/icecast -- -c /etc/icecast.xml
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Icecast 2"
+ start-stop-daemon --stop --pidfile /var/run/icecast.pid --name icecast
+ eend $?
+}