summaryrefslogtreecommitdiffstats
path: root/testing/igmpproxy/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-28 08:05:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-28 08:05:41 +0000
commit9088f350abed6419b704c869c8c15e39151bb0b3 (patch)
treee684e02d7b1dec4146100e10c40b15e83b0d2a38 /testing/igmpproxy/APKBUILD
parentf1311ac2aef4cea98dc075d22ba5d0952a706c02 (diff)
downloadaports-9088f350abed6419b704c869c8c15e39151bb0b3.tar.bz2
aports-9088f350abed6419b704c869c8c15e39151bb0b3.tar.xz
testing/igmpproxy: new aport
a simple dynamic Multicast Routing Daemon using only IGMP signalling" http://sourceforge.net/projects/igmpproxy/"
Diffstat (limited to 'testing/igmpproxy/APKBUILD')
-rw-r--r--testing/igmpproxy/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/igmpproxy/APKBUILD b/testing/igmpproxy/APKBUILD
new file mode 100644
index 00000000..5c0358d9
--- /dev/null
+++ b/testing/igmpproxy/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=igmpproxy
+pkgver=0.1_beta4
+pkgrel=0
+pkgdesc="a simple dynamic Multicast Routing Daemon using only IGMP signalling"
+url="http://sourceforge.net/projects/igmpproxy/"
+license="GPL"
+depends="uclibc"
+makedepends=""
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="0a16178aeca5d1bf54c129cec9597f85 igmpproxy-0.1_beta4.tar.gz"