summaryrefslogtreecommitdiffstats
path: root/testing/kvm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-01-14 14:03:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-01-14 14:03:32 +0000
commit785a3cadfeeef7d301c803e6f422720bfd0bf8ce (patch)
tree86097d52f89f400ef99bb947986003fa930ed330 /testing/kvm
parenta4fe249127b31852dec889ce8f13cee0c0a3dbc8 (diff)
downloadaports-785a3cadfeeef7d301c803e6f422720bfd0bf8ce.tar.bz2
aports-785a3cadfeeef7d301c803e6f422720bfd0bf8ce.tar.xz
testing/kvm: new aport
Diffstat (limited to 'testing/kvm')
-rw-r--r--testing/kvm/APKBUILD33
-rw-r--r--testing/kvm/kvm-82-uclibc.patch14
2 files changed, 47 insertions, 0 deletions
diff --git a/testing/kvm/APKBUILD b/testing/kvm/APKBUILD
new file mode 100644
index 00000000..ccac7e5e
--- /dev/null
+++ b/testing/kvm/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=kvm
+pkgver=83
+pkgrel=0
+pkgdesc="kernel-based virtual machine"
+url="http://kvm.qumranet.com"
+license='GPL'
+depends="uclibc"
+makedepends="ncurses-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ kvm-82-uclibc.patch
+ "
+subpackages=""
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for i in ../*.patch; do
+ msg "Applying $i"
+ patch -p1 < $i || return 1;
+ done
+
+ ./configure --prefix=/usr \
+ --disable-gfx-check \
+ --disable-sdl \
+ --qemu-ldflags=-nopie
+
+ make libkvm || return 1
+ make qemu || return 1
+ make DESTDIR="$pkgdir"/ kcmd="#" install
+}
+
+md5sums="dfb3cc36029d84e83c5006c600337754 kvm-83.tar.gz
+c439025cbfe89b35c2ae78aa481eb93f kvm-82-uclibc.patch"
diff --git a/testing/kvm/kvm-82-uclibc.patch b/testing/kvm/kvm-82-uclibc.patch
new file mode 100644
index 00000000..488be77d
--- /dev/null
+++ b/testing/kvm/kvm-82-uclibc.patch
@@ -0,0 +1,14 @@
+--- kvm-82.orig/qemu/configure Wed Jan 14 13:40:28 2009
++++ kvm-82/qemu/configure Wed Jan 14 13:41:28 2009
+@@ -1068,7 +1068,10 @@
+ cat > $TMPC <<EOF
+ #include <signal.h>
+ #include <time.h>
+-int main(void) { clockid_t id; return clock_gettime(id, NULL); }
++int main(void) { clockid_t id; timer_t tid;
++ return clock_gettime(id, NULL) + timer_delete(tid);
++}
++
+ EOF
+
+ rt=no