summaryrefslogtreecommitdiffstats
path: root/testing/lua-curl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-17 10:55:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-17 10:55:42 +0000
commit9cd36fcb4c530d0a7472491cafc87db69597b5d9 (patch)
tree251ee00559a58760c93c42993f6e7df1a4a037b2 /testing/lua-curl
parent80c202315d658f8aff2f1fc37b6d19602bb0f794 (diff)
downloadaports-9cd36fcb4c530d0a7472491cafc87db69597b5d9.tar.bz2
aports-9cd36fcb4c530d0a7472491cafc87db69597b5d9.tar.xz
testing/lua-curl: new aport
Lua bindings to cURL library http://lua-curl.luaforge.net/
Diffstat (limited to 'testing/lua-curl')
-rw-r--r--testing/lua-curl/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/lua-curl/APKBUILD b/testing/lua-curl/APKBUILD
new file mode 100644
index 00000000..849b651c
--- /dev/null
+++ b/testing/lua-curl/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-curl
+pkgver=0.2
+pkgrel=0
+pkgdesc="Lua bindings to cURL library"
+url="http://lua-curl.luaforge.net/"
+license="MIT/X11"
+depends=
+makedepends="lua-dev curl-dev"
+install=
+subpackages=""
+source="http://luaforge.net/frs/download.php/2634/lua-curl-0.2.tar.gz"
+
+_builddir="$srcdir"/lua-curl-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+ rm -f "$pkgdir"/usr/lib/lua/5.1/cURL.la
+}
+
+md5sums="c15599e1147f76261f03a00088946d9d lua-curl-0.2.tar.gz"