summaryrefslogtreecommitdiffstats
path: root/testing/lua-filesystem
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-24 14:20:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-24 14:20:24 +0000
commit7f1321f84ac018ae5cbd1d228f7597ff31a2df77 (patch)
tree660b677b1bd3090231944c4b174e66756cfa539f /testing/lua-filesystem
parenta816d230e1457f50eb5752c4bf34b422f30b258c (diff)
downloadaports-7f1321f84ac018ae5cbd1d228f7597ff31a2df77.tar.bz2
aports-7f1321f84ac018ae5cbd1d228f7597ff31a2df77.tar.xz
testing/lua-filesystem: new aport
Lua library to complement the set of functions related to file systems http://www.keplerproject.org/luafilesystem/
Diffstat (limited to 'testing/lua-filesystem')
-rw-r--r--testing/lua-filesystem/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/lua-filesystem/APKBUILD b/testing/lua-filesystem/APKBUILD
new file mode 100644
index 00000000..cf07eb5a
--- /dev/null
+++ b/testing/lua-filesystem/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor:
+# Maintainer:
+pkgname=lua-filesystem
+pkgver=1.4.2
+pkgrel=0
+pkgdesc="Lua library to complement the set of functions related to file systems"
+url="http://www.keplerproject.org/luafilesystem/"
+license="GPL"
+depends=
+makedepends="lua-dev"
+install=
+subpackages=
+source="http://luaforge.net/frs/download.php/3931/luafilesystem-1.4.2.tar.gz"
+
+_builddir="$srcdir"/luafilesystem-$pkgver
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make LUA_LIBDIR="$pkgdir"/usr/lib/lua/5.1 install
+}
+
+md5sums="8e7b2a9b899d669280456d0f95afd961 luafilesystem-1.4.2.tar.gz"