summaryrefslogtreecommitdiffstats
path: root/testing/madwimax/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-03 10:49:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-03 10:49:14 +0000
commit53f078975d6c0ab137740eb66a2b19b83c4d7976 (patch)
tree5b61de5691cd9ed3eb1a3d75d7d0f4a9535fbead /testing/madwimax/APKBUILD
parent97f8ecee5b90f72ea183a41a76e2d72ed4a41db6 (diff)
downloadaports-53f078975d6c0ab137740eb66a2b19b83c4d7976.tar.bz2
aports-53f078975d6c0ab137740eb66a2b19b83c4d7976.tar.xz
testing/madwimax: separate package() function
Diffstat (limited to 'testing/madwimax/APKBUILD')
-rw-r--r--testing/madwimax/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/testing/madwimax/APKBUILD b/testing/madwimax/APKBUILD
index 251ff801..70367a67 100644
--- a/testing/madwimax/APKBUILD
+++ b/testing/madwimax/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=madwimax
pkgver=0.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="WiMAX driver for the Samsung SWC-U200 and similar USB modems"
url="http://code.google.com/p/madwimax/"
license="GPL-2"
@@ -12,15 +12,19 @@ install=
subpackages="$pkgname-doc"
source="http://madwimax.googlecode.com/files/madwimax-0.1.1.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --without-man-pages \
+ || return 1
+ make || return 1
+}
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --without-man-pages \
- || return 1
- make || return 1
- make DESTDIR="$pkgdir" install
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
#2009-10-07,SP: you can start it simply by /usr/sbin/madwimax -d
#, so no init.d script so far...