summaryrefslogtreecommitdiffstats
path: root/testing/madwimax/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-08 20:21:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-08 20:21:40 +0000
commit7f3b1f612445d16212fbeddff86c453a50d81d6b (patch)
tree44bebbf69d749cff222cbcfc59c5aaf3c603d547 /testing/madwimax/APKBUILD
parent0e73bc9f5f2c536807b52ad12ff70cb03cd9e7bf (diff)
downloadaports-7f3b1f612445d16212fbeddff86c453a50d81d6b.tar.bz2
aports-7f3b1f612445d16212fbeddff86c453a50d81d6b.tar.xz
testing/madwimax: new aport
WiMAX driver for the Samsung SWC-U200 and similar USB modems http://code.google.com/p/madwimax/
Diffstat (limited to 'testing/madwimax/APKBUILD')
-rw-r--r--testing/madwimax/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/madwimax/APKBUILD b/testing/madwimax/APKBUILD
new file mode 100644
index 00000000..251ff801
--- /dev/null
+++ b/testing/madwimax/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Sergey
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=madwimax
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="WiMAX driver for the Samsung SWC-U200 and similar USB modems"
+url="http://code.google.com/p/madwimax/"
+license="GPL-2"
+depends=
+makedepends="pkgconfig libusb-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://madwimax.googlecode.com/files/madwimax-0.1.1.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --without-man-pages \
+ || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+#2009-10-07,SP: you can start it simply by /usr/sbin/madwimax -d
+#, so no init.d script so far...
+
+}
+
+md5sums="4ebd2d74e887e6f9d6f23067a4ad8272 madwimax-0.1.1.tar.gz"