summaryrefslogtreecommitdiffstats
path: root/testing/prosody
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-06-08 15:00:56 +0000
committerMichael Mason <ms13sp@gmail.com>2009-06-08 15:00:56 +0000
commitf9b478494e821804a3c5cee3912a1f970c2b7ca3 (patch)
tree0c7b35640c839161b32c82e34746f1ab14835e61 /testing/prosody
parentaf73d3395ad713e014efb49fc60b0c9d99a11e1f (diff)
downloadaports-f9b478494e821804a3c5cee3912a1f970c2b7ca3.tar.bz2
aports-f9b478494e821804a3c5cee3912a1f970c2b7ca3.tar.xz
unstable/prosody move to testing/prosody
Diffstat (limited to 'testing/prosody')
-rw-r--r--testing/prosody/APKBUILD46
-rw-r--r--testing/prosody/Makefile-0.4.2.patch13
-rw-r--r--testing/prosody/prosody.cfg.lua107
-rw-r--r--testing/prosody/prosody.initd43
-rw-r--r--testing/prosody/prosody.post-install6
-rw-r--r--testing/prosody/prosody.pre-install9
6 files changed, 224 insertions, 0 deletions
diff --git a/testing/prosody/APKBUILD b/testing/prosody/APKBUILD
new file mode 100644
index 00000000..60ad4e9c
--- /dev/null
+++ b/testing/prosody/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+pkgname=prosody
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="Lua based Jabber/XMPP server"
+url="http://prosody.im/"
+license="MIT"
+depends="uclibc lua libidn openssl luasocket luaexpat"
+makedepends="lua-dev libidn-dev openssl-dev"
+install="prosody.pre-install prosody.post-install"
+subpackages=""
+source="http://prosody.im/downloads/source/$pkgname-$pkgver.tar.gz
+ $pkgname.cfg.lua
+ $pkgname.initd
+ $install
+ Makefile-0.4.2.patch
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch Makefile "$startdir/Makefile-0.4.2.patch" || return 1
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/prosody \
+ --with-lua=/usr/bin \
+ --with-lua-lib=/usr/lib \
+ --with-lua-include=/usr/include
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+ install -d "$pkgdir/var/log/prosody" || return 1
+ install -d "$pkgdir/var/run/prosody" || return 1
+ install -D -m755 "$srcdir"/"$pkgname".initd "$pkgdir"/etc/init.d/"$pkgname"
+
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+md5sums="2669478311b3a67522669acdf03cf85c prosody-0.4.2.tar.gz
+f42039e5a342fe62cd7e491546338aaa prosody.cfg.lua
+c161a875295b45241229eb6db65211e8 prosody.initd
+08484f183ba39233337d3fbc92cffadc prosody.pre-install
+8202a40bf6de7cbacbaf76f2985aa220 prosody.post-install
+684d033dac42399a245c061c9a374e1b Makefile-0.4.2.patch"
diff --git a/testing/prosody/Makefile-0.4.2.patch b/testing/prosody/Makefile-0.4.2.patch
new file mode 100644
index 00000000..facfa2f9
--- /dev/null
+++ b/testing/prosody/Makefile-0.4.2.patch
@@ -0,0 +1,13 @@
+--- src/prosody-0.4.2/Makefile.org Thu Jun 4 13:44:20 2009
++++ src/prosody-0.4.2/Makefile Thu Jun 4 13:44:11 2009
+@@ -19,8 +19,8 @@
+ install -d $(BIN) $(CONFIG) $(MODULES) $(SOURCE) $(DATA)
+ install -d $(CONFIG)/certs
+ install -d $(SOURCE)/core $(SOURCE)/net $(SOURCE)/util
+- install ./prosody.install $(BIN)/prosody
+- install ./prosodyctl.install $(BIN)/prosodyctl
++ install -m755 ./prosody.install $(BIN)/prosody
++ install -m755 ./prosodyctl.install $(BIN)/prosodyctl
+ install -m644 core/* $(SOURCE)/core
+ install -m644 net/* $(SOURCE)/net
+ install -m644 util/* $(SOURCE)/util
diff --git a/testing/prosody/prosody.cfg.lua b/testing/prosody/prosody.cfg.lua
new file mode 100644
index 00000000..99df66ad
--- /dev/null
+++ b/testing/prosody/prosody.cfg.lua
@@ -0,0 +1,107 @@
+-- Prosody Configuration File
+--
+-- If it wasn't already obvious, -- starts a comment, and all text after it on
+-- a line is ignored by Prosody.
+--
+-- The config is split into sections, a global section, and one for each
+-- defined host that we serve. You can add as many host sections as you like.
+--
+-- Lists are written { "like", "this", "one" }
+-- Lists can also be of { 1, 2, 3 } numbers, etc.
+-- Either commas, or semi-colons; may be used as seperators.
+--
+-- A table is a list of values, except each value has a name. An example would
+-- be:
+--
+-- logging = { type = "html", directory = "/var/logs", rotate = "daily" }
+--
+-- Whitespace (that is tabs, spaces, line breaks) is mostly insignificant, so
+-- can
+-- be placed anywhere
+-- that you deem fitting.
+--
+-- Tip: You can check that the syntax of this file is correct when you have
+-- finished by running: luac -p prosody.cfg.lua
+-- If there are any errors, it will let you know what and where they are,
+-- otherwise it will keep quiet.
+--
+-- Good luck, and happy Jabbering!
+
+-- Global settings go in this section
+Host "*"
+ -- This is the list of modules Prosody will load on startup.
+ -- It looks for mod_modulename.lua in the plugins folder, so make sure that
+ -- exists too.
+ modules_enabled = {
+ -- Generally required
+ "roster"; -- Allow users to have a roster. Recommended ;)
+ "saslauth"; -- Authentication for clients and servers. Recommended
+ -- if you want to log in.
+ "tls"; -- Add support for secure TLS on c2s/s2s connections
+ "dialback"; -- s2s dialback support
+ "disco"; -- Service discovery
+
+ -- Not essential, but recommended
+ "private"; -- Private XML storage (for room bookmarks, etc.)
+ "vcard"; -- Allow users to set vCards
+
+ -- Nice to have
+ "legacyauth"; -- Legacy authentication. Only used by some old
+ -- clients and bots.
+ "version"; -- Replies to server version requests
+ "uptime"; -- Report how long server has been running
+ "time"; -- Let others know the time here on this server
+ "ping"; -- Replies to XMPP pings with pongs
+
+ -- Required for daemonizing and logging
+ "posix"; -- POSIX functionality, sends server to background,
+ -- enables syslog, etc.
+
+ -- Other specific functionality
+ "register"; -- Allow users to register on this server using a
+ -- client
+ --"console"; -- telnet to port 5582 (needs console_enabled = true)
+ --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
+ --"httpserver"; -- Serve static files from a directory over HTTP
+ }
+
+ -- These are the SSL/TLS-related settings. If you don't want to use
+ -- SSL/TLS, you may comment or remove this
+ --ssl = {
+ -- key = "/etc/prosody/certs/localhost.key";
+ -- certificate = "/etc/prosody/certs/localhost.cert";
+ --}
+
+ log = {
+ -- Log all error messages to prosody.err
+ { levels = { min = "error" }, to = "file", timestamps = true,
+ filename = "/var/log/prosody/prosody.err" };
+ -- Log everything of level "info" and higher (that is, all except
+ -- "debug" messages) to prosody.log
+ { levels = { min = "info" }, to = "file", timestamps = true,
+ filename = "/var/log/prosody/prosody.log" };
+ }
+
+ -- Required for proper daemonization support
+ pidfile = "/var/run/prosody/prosody.pid"
+
+-- This allows clients to connect to localhost. No harm in it.
+Host "localhost"
+
+-- Section for example.com
+-- (replace example.com with your domain name)
+Host "example.com"
+ -- Assign this host a certificate for TLS, otherwise it would use the one
+ -- set in the global section (if any).
+ -- Note that old-style SSL on port 5223 only supports one certificate, and
+ -- will always use the global one.
+ --ssl = {
+ -- key = "/etc/prosody/certs/example.com.key";
+ -- certificate = "/etc/prosody/certs/example.com.crt";
+ --}
+
+ enabled = false -- This will disable the host, preserving the config, but
+ -- denying connections
+
+-- Set up a MUC (multi-user chat) room server on conference.localhost:
+Component "conference.localhost" "muc"
diff --git a/testing/prosody/prosody.initd b/testing/prosody/prosody.initd
new file mode 100644
index 00000000..1c88672b
--- /dev/null
+++ b/testing/prosody/prosody.initd
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+
+# Sample init.d file for alpine linux.
+
+NAME=prosody
+DAEMON=/usr/bin/$NAME
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${NAME}"
+ /usr/bin/prosodyctl start
+# start-stop-daemon --start --quiet --background \
+# --make-pidfile --pidfile /var/run/${NAME}/${NAME}.pid \
+# --chuid ${USER}:${GROUP} \
+# --exec ${DAEMON} -- ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${NAME}"
+ /usr/bin/prosodyctl stop
+# start-stop-daemon --stop --quiet \
+# --exec ${DAEMON} \
+# --pidfile /var/run/${NAME}/${NAME}.pid \
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${NAME}"
+ if ! service_started "${NAME}" ; then
+ eend 1 "${NAME} is not started"
+ return 1
+ fi
+ /usr/bin/prosodyctl stop
+ /usr/bin/prosodyctl start
+# start-stop-daemon --stop --oknodo --signal HUP \
+# --exec ${DAEMON} --pidfile /var/run/${NAME}/${NAME}.pid
+ eend $?
+}
+
diff --git a/testing/prosody/prosody.post-install b/testing/prosody/prosody.post-install
new file mode 100644
index 00000000..2f8f69cd
--- /dev/null
+++ b/testing/prosody/prosody.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+chown prosody:prosody var/lib/prosody
+chown prosody:prosody var/log/prosody
+chown prosody:prosody var/run/prosody
+
diff --git a/testing/prosody/prosody.pre-install b/testing/prosody/prosody.pre-install
new file mode 100644
index 00000000..db63efa1
--- /dev/null
+++ b/testing/prosody/prosody.pre-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+user=prosody
+home=/var/lib/prosody
+adduser -h $home -s /bin/false -D $user 2>/dev/null
+mkdir -p $home
+chown $user:$user $home
+exit 0
+