summaryrefslogtreecommitdiffstats
path: root/testing/python26-setuptools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-03 07:41:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-03 07:41:11 +0000
commit09ce0508afe6568cf580f53fb9952963125fff43 (patch)
treebe336c26f16f7fd1e5c5454738c9332da34fb2d1 /testing/python26-setuptools
parent9ad548df8aa2a860ca311453ed3d6a98962f32f5 (diff)
downloadaports-09ce0508afe6568cf580f53fb9952963125fff43.tar.bz2
aports-09ce0508afe6568cf580f53fb9952963125fff43.tar.xz
Revert "testing/*: remove from stable branch"
This reverts commit 9ad548df8aa2a860ca311453ed3d6a98962f32f5. I'll delete them one by one.
Diffstat (limited to 'testing/python26-setuptools')
-rw-r--r--testing/python26-setuptools/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/python26-setuptools/APKBUILD b/testing/python26-setuptools/APKBUILD
new file mode 100644
index 00000000..e8322dd5
--- /dev/null
+++ b/testing/python26-setuptools/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Andrew Manison <amanison@anselsystems.com>
+# Maintainer:
+pkgname=python26-setuptools
+_pkgname=${pkgname#python26-}
+pkgver=0.6c11
+pkgrel=0
+pkgdesc="setuptools is a collection of enhancements to the Python distutils"
+url="http://pypi.python.org/pypi/setuptools"
+license="PSF"
+depends="python"
+makedepends="python-dev"
+install=
+subpackages=""
+source="http://pypi.python.org/packages/source/s/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ mkdir -p "$pkgdir"/usr/lib/python2.6/site-packages
+ python setup.py install --root="$pkgdir"
+ echo "/usr/lib/python2.6/site-packages/$_pkgname-$pkgver-py2.6.egg" > "$pkgdir"/usr/lib/python2.6/site-packages/$_pkgname.pth
+
+ # we don't provide a non-suffixed easy_install
+ echo "Removing non-suffixed easy_install ( $pkgdir/usr/bin/easy_install)"
+ rm "$pkgdir"/usr/bin/easy_install
+}
+
+md5sums="7df2a529a074f613b509fb44feefe74e setuptools-0.6c11.tar.gz"