summaryrefslogtreecommitdiffstats
path: root/testing/rrdbot
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-15 16:00:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-15 16:00:59 +0000
commite62eb554b6ab8b056d5902c91ba6d6cc80997435 (patch)
tree1711e8bb2632b7b28e1548f12ee2656585cbaed4 /testing/rrdbot
parenta2c7615dae18d300e807ebc12c279f88573b0149 (diff)
downloadaports-e62eb554b6ab8b056d5902c91ba6d6cc80997435.tar.bz2
aports-e62eb554b6ab8b056d5902c91ba6d6cc80997435.tar.xz
testing/rrdbot: new aport
an SNMP polling daemon which writes the polled values to an RRD database http://memberwebs.com/stef/software/rrdbot/
Diffstat (limited to 'testing/rrdbot')
-rw-r--r--testing/rrdbot/APKBUILD46
-rw-r--r--testing/rrdbot/rrdbot.post-install4
-rw-r--r--testing/rrdbot/rrdbot.pre-install7
-rw-r--r--testing/rrdbot/rrdbotd.confd7
-rw-r--r--testing/rrdbot/rrdbotd.initd28
5 files changed, 92 insertions, 0 deletions
diff --git a/testing/rrdbot/APKBUILD b/testing/rrdbot/APKBUILD
new file mode 100644
index 00000000..d1f1e17d
--- /dev/null
+++ b/testing/rrdbot/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=rrdbot
+pkgver=0.9.6
+pkgrel=0
+pkgdesc="an SNMP polling daemon which writes the polled values to an RRD database"
+url="http://memberwebs.com/stef/software/rrdbot/"
+license="BSD"
+depends=
+makedepends=rrdtool-dev
+install="$pkgname.pre-install $pkgname.post-install"
+subpackages="$pkgname-doc"
+source="http://memberwebs.com/stef/software/rrdbot/rrdbot-$pkgver.tar.gz
+ rrdbotd.initd
+ rrdbotd.confd
+ "
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ install -m755 -D "$srcdir"/rrdbotd.initd "$pkgdir"/etc/init.d/rrdbotd
+ install -m644 -D "$srcdir"/rrdbotd.confd "$pkgdir"/etc/conf.d/rrdbotd
+}
+
+md5sums="8329c8f58136158b25c3179e825c66e6 rrdbot-0.9.6.tar.gz
+e74785806860537d38a5863fc90b324f rrdbotd.initd
+cbcac88f5b728b1441891947a4babbcb rrdbotd.confd"
diff --git a/testing/rrdbot/rrdbot.post-install b/testing/rrdbot/rrdbot.post-install
new file mode 100644
index 00000000..0586fcd5
--- /dev/null
+++ b/testing/rrdbot/rrdbot.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+# add something which happends after install
+
diff --git a/testing/rrdbot/rrdbot.pre-install b/testing/rrdbot/rrdbot.pre-install
new file mode 100644
index 00000000..2c35d02d
--- /dev/null
+++ b/testing/rrdbot/rrdbot.pre-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# this user should be included in alpine-baselayout-1.2.
+# included here for backward compability.
+adduser -H -s /bin/false -D rrdbotd 2>/dev/null
+
+exit 0
diff --git a/testing/rrdbot/rrdbotd.confd b/testing/rrdbot/rrdbotd.confd
new file mode 100644
index 00000000..486252b0
--- /dev/null
+++ b/testing/rrdbot/rrdbotd.confd
@@ -0,0 +1,7 @@
+# Sample conf.d file for alpine linux
+
+#
+# Specify daemon options here.
+#
+
+sample_opts=""
diff --git a/testing/rrdbot/rrdbotd.initd b/testing/rrdbot/rrdbotd.initd
new file mode 100644
index 00000000..d0fcdc4a
--- /dev/null
+++ b/testing/rrdbot/rrdbotd.initd
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+
+name=rrdbotd
+daemon=/usr/sbin/$name
+pidfile=${rrdbotd_pidfile:-/var/run/rrdbotd/rrdbotd.pid}
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting ${name}"
+ start-stop-daemon --start --quiet \
+ --pidfile "$pidfile" \
+ --chuid ${rrdbotd_user:-rrdbotd}:${rrdbotd_group:-rrdbotd} \
+ --exec ${daemon} -- ${rrdbotd_opts} -p "$pidfile"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${name}"
+ start-stop-daemon --stop --quiet \
+ --pidfile "$pidfile" \
+ --exec ${daemon}
+ eend $?
+}
+