summaryrefslogtreecommitdiffstats
path: root/testing/rtnppd
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2010-03-30 14:56:43 +0000
committerMichael Mason <ms13sp@gmail.com>2010-03-30 14:56:43 +0000
commit75d7d985d22cb30d79c0f0b1dc187d2b01fcfbfc (patch)
treee9ef5ecaf0b5b21d9dfcf4b9c0e2c521a7db65d5 /testing/rtnppd
parent9df1181ade37a4cbc3bb9ca0d54f44df0c8f1198 (diff)
downloadaports-75d7d985d22cb30d79c0f0b1dc187d2b01fcfbfc.tar.bz2
aports-75d7d985d22cb30d79c0f0b1dc187d2b01fcfbfc.tar.xz
testing/rtnppd Added with postgresql support
Diffstat (limited to 'testing/rtnppd')
-rw-r--r--testing/rtnppd/APKBUILD40
-rw-r--r--testing/rtnppd/Makefile.patch13
-rw-r--r--testing/rtnppd/rtnppd.confd1
-rw-r--r--testing/rtnppd/rtnppd.initd21
4 files changed, 75 insertions, 0 deletions
diff --git a/testing/rtnppd/APKBUILD b/testing/rtnppd/APKBUILD
new file mode 100644
index 00000000..f608ec7f
--- /dev/null
+++ b/testing/rtnppd/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=rtnppd
+_builddir="$pkgname"
+pkgver=1.7b
+pkgrel=0
+pkgdesc="A program route TNPP 3.8 (Telocator Network Paging Protocol) packets between serial and other links"
+url="http://sourceforge.net/projects/rtnppd/"
+license="GPL"
+depends=""
+makedepends="postgresql-dev"
+install=
+subpackages=""
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ Makefile.patch
+ $pkgname.initd
+ $pkgname.confd"
+
+build() {
+ cd "$srcdir"/"$_builddir"
+ patch -p1 < ../Makefile.patch || return 1
+ make || return 1
+}
+package() {
+ cd "$srcdir"/"$_builddir"
+ #make DESTDIR="$pkgdir" install
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+ install -m755 -D ./rtnppd "$pkgdir"/usr/sbin/rtnppd
+ install -m755 -D ./tnpppage "$pkgdir"/usr/sbin/tnpppage
+ install -m755 -D ./testq "$pkgdir"/usr/sbin/testq
+ install -m644 -D ./rtnppd.conf "$pkgdir"/etc/rtnppd/rtnppd.conf
+ install -m644 -D ./tnpp_dev.conf "$pkgdir"/etc/rtnppd/tnpp_dev.conf
+ install -m644 -D ./tnpp_trans.conf "$pkgdir"/etc/rtnppd/tnpp_trans.conf
+}
+
+md5sums="3f484a7307b1c237652135fcc26ee798 rtnppd-1.7b.tar.gz
+17ec69098e967021face024251da20fc Makefile.patch
+9bb8ca4d1f073d0b3663d368ff322ecf rtnppd.initd
+58b8113f483bd824e9ef82fbfdf743d8 rtnppd.confd"
diff --git a/testing/rtnppd/Makefile.patch b/testing/rtnppd/Makefile.patch
new file mode 100644
index 00000000..1d7e2572
--- /dev/null
+++ b/testing/rtnppd/Makefile.patch
@@ -0,0 +1,13 @@
+--- rtnppd.orig/Makefile Tue Mar 30 14:46:20 2010
++++ rtnppd/Makefile Tue Mar 30 14:46:30 2010
+@@ -23,8 +23,8 @@
+
+ # Use PostgreSQL-server (with includes in /usr/include/pgsql
+ # and libs in /usr/lib
+-#CFLAGS = -DUSE_POSTGRESQL -I/usr/include/pgsql
+-#LIBS = -lpq
++CFLAGS = -DUSE_POSTGRESQL -I/usr/include/pgsql
++LIBS = -lpq
+
+ PREFIX = /usr/local
+ INCLUDES = -I./
diff --git a/testing/rtnppd/rtnppd.confd b/testing/rtnppd/rtnppd.confd
new file mode 100644
index 00000000..c2622255
--- /dev/null
+++ b/testing/rtnppd/rtnppd.confd
@@ -0,0 +1 @@
+#RTNPPD_OPTS=""
diff --git a/testing/rtnppd/rtnppd.initd b/testing/rtnppd/rtnppd.initd
new file mode 100644
index 00000000..6fcd6c2b
--- /dev/null
+++ b/testing/rtnppd/rtnppd.initd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DAEMON=/usr/sbin/rtnppd
+USER=rtnppd
+
+start() {
+ ebegin "Starting $(basename $DAEMON)"
+ start-stop-daemon --start --user ${USER} --exec ${DAEMON} \
+ -- ${RTNPPD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $(basename $DAEMON)"
+ start-stop-daemon --stop --exec ${DAEMON}
+ eend $?
+}
+