summaryrefslogtreecommitdiffstats
path: root/testing/sems/0003-cc-and-cflags.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-12-18 09:40:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-12-18 09:40:02 +0000
commitae4d66b1bade676c8053288d05fa202b65684be1 (patch)
treec8b4b4d86990c85fb542813e842df55e61d242e2 /testing/sems/0003-cc-and-cflags.patch
parent0b2726014c620015f9e0c4b2d054f379090cc5dd (diff)
downloadaports-ae4d66b1bade676c8053288d05fa202b65684be1.tar.bz2
aports-ae4d66b1bade676c8053288d05fa202b65684be1.tar.xz
testing/sems: build fix
fixes #222
Diffstat (limited to 'testing/sems/0003-cc-and-cflags.patch')
-rw-r--r--testing/sems/0003-cc-and-cflags.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/sems/0003-cc-and-cflags.patch b/testing/sems/0003-cc-and-cflags.patch
new file mode 100644
index 00000000..a17c1f77
--- /dev/null
+++ b/testing/sems/0003-cc-and-cflags.patch
@@ -0,0 +1,45 @@
+From b411106aa364fd13e87d85e94ade9eeb1d6aeb8e Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 18 Dec 2009 09:13:58 +0000
+Subject: [PATCH] cc and cflags
+
+---
+ core/plug-in/binrpcctrl/Makefile | 2 +-
+ core/plug-in/gsm/gsm-1.0-pl10/Makefile | 6 +++---
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/core/plug-in/binrpcctrl/Makefile b/core/plug-in/binrpcctrl/Makefile
+index 71680f3..753779a 100644
+--- a/core/plug-in/binrpcctrl/Makefile
++++ b/core/plug-in/binrpcctrl/Makefile
+@@ -35,7 +35,7 @@ libbinrpc:
+ $(MAKE) all
+
+ $(LIBBINRPC_LIB)/libbinrpc.a:
+- $(MAKE) -C $(LIBBINRPC_DIR) all CC=$(CC) LD=$(LD) AR=$(AR)
++ $(MAKE) -C $(LIBBINRPC_DIR) all CC="$(CC)" LD="$(LD)" AR="$(AR)"
+
+ libbinrpc_clean:
+ $(MAKE) -C $(LIBBINRPC_DIR) clean
+diff --git a/core/plug-in/gsm/gsm-1.0-pl10/Makefile b/core/plug-in/gsm/gsm-1.0-pl10/Makefile
+index 396fb7f..6a1a1a1 100644
+--- a/core/plug-in/gsm/gsm-1.0-pl10/Makefile
++++ b/core/plug-in/gsm/gsm-1.0-pl10/Makefile
+@@ -43,11 +43,11 @@ WAV49 =
+ # CC = /usr/lang/acc
+ # CCFLAGS = -c -O
+
+-CC = gcc -ansi -pedantic
+-CCFLAGS = -c -O2 -DNeedFunctionPrototypes=1 -fPIC
++CC ?= gcc
++CCFLAGS += -ansi -pedantic -c -O2 -DNeedFunctionPrototypes=1 -fPIC
+ MODULE_CFLAGS = -I inc -DHAS_STDLIB_H
+
+-LD = $(CC)
++LD ?= $(CC)
+
+ # LD = gcc
+ # LDFLAGS =
+--
+1.6.5.6
+