summaryrefslogtreecommitdiffstats
path: root/testing/util-vserver
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-07 14:47:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-07 14:49:20 +0000
commit7435e8a2f9d3fa13f078808f04f00d67685395de (patch)
treeb58f261c45ba5dda1ab1628e42efd80bcd6cfc43 /testing/util-vserver
parent5ad962dfec7ed2b87a90ac3dd79714db73ab506b (diff)
downloadaports-7435e8a2f9d3fa13f078808f04f00d67685395de.tar.bz2
aports-7435e8a2f9d3fa13f078808f04f00d67685395de.tar.xz
testing/util-vserver: build with busybox only
Diffstat (limited to 'testing/util-vserver')
-rw-r--r--testing/util-vserver/APKBUILD22
-rw-r--r--testing/util-vserver/alpine.patch21
-rw-r--r--testing/util-vserver/chmod.patch12
-rw-r--r--testing/util-vserver/ensc_pathprog.patch14
-rw-r--r--testing/util-vserver/validate.patch10
5 files changed, 75 insertions, 4 deletions
diff --git a/testing/util-vserver/APKBUILD b/testing/util-vserver/APKBUILD
index 802315b9..2ced5a0f 100644
--- a/testing/util-vserver/APKBUILD
+++ b/testing/util-vserver/APKBUILD
@@ -2,31 +2,45 @@
pkgname=util-vserver
pkgver=0.30.216_pre2841
_realver=0.30.216-pre2841
-pkgrel=1
+pkgrel=2
pkgdesc="Linux-VServer admin utilities"
url="http://www.nongnu.org/util-vserver/"
license="GPL"
# needs coreutils for touch -t
makedepends="iptables-dev e2fsprogs-dev beecrypt-dev autoconf automake
- pkgconfig coreutils"
+ pkgconfig libtool"
depends="bash"
source="http://people.linux-vserver.org/~dhozac/t/uv-testing/util-vserver-$_realver.tar.bz2
+ chmod.patch
+ ensc_pathprog.patch
+ validate.patch
"
subpackages="$pkgname-doc $pkgname-dev"
build() {
local i
cd "$srcdir"/$pkgname-$_realver
+ patch -p1 -i ../chmod.patch || return 1
+ patch -p1 -i ../ensc_pathprog.patch || return 1
+ patch -p1 -i ../validate.patch || return 1
+ aclocal -I m4 && autoconf && automake && libtoolize || return 1
+
+ # this is an ugly workaround
+ sed -i -e "s:as_echo=.*:as_echo=echo:g" configure
./configure --prefix=/usr \
--mandir=/usr/share/man \
--sysconfdir=/etc \
--with-initscripts=gentoo \
- --localstatedir=/var
+ --localstatedir=/var \
+ || return 1
make || return 1
make DESTDIR="$pkgdir/" install install-distribution
}
-md5sums="71c3f2012d0159aac22fee098be063e9 util-vserver-0.30.216-pre2841.tar.bz2"
+md5sums="71c3f2012d0159aac22fee098be063e9 util-vserver-0.30.216-pre2841.tar.bz2
+73c7437dea6937a57cf38d166ef83c09 chmod.patch
+ff8f561f672524eb46fe633f584ef60e ensc_pathprog.patch
+da8b70c4fd40e68894b3903ffd121397 validate.patch"
diff --git a/testing/util-vserver/alpine.patch b/testing/util-vserver/alpine.patch
new file mode 100644
index 00000000..a9914a4b
--- /dev/null
+++ b/testing/util-vserver/alpine.patch
@@ -0,0 +1,21 @@
+diff -ru a/distrib/alpine/initpost b/distrib/alpine/initpost
+--- a/distrib/alpine/initpost 2009-10-02 18:36:00.000000000 +0000
++++ b/distrib/alpine/initpost 2009-10-02 18:42:35.000000000 +0000
+@@ -24,7 +24,7 @@
+ cd "$vdir"
+
+ echo ">>> Creating missing dirs..."
+-$_CHROOT_SH mkdir proc sys dev home etc etc/rcL.d etc/rcK.d 2>/dev/null
++$_CHROOT_SH mkdir -p proc sys dev home etc 2>/dev/null
+
+ # remove mtab which is a link
+ if test -e "$vdir/etc/mtab"; then
+@@ -37,7 +37,7 @@
+ $_VSERVER "$vserver" stop &>/dev/null || true
+ $_VSERVER "$vserver" start --rescue --rescue-init /bin/busybox sh -c '
+ /bin/busybox --install -s
+- /sbin/rc_add -s 20 -k syslog
++ /sbin/rc-update add syslog boot
+ '
+
+ # set up hostname
diff --git a/testing/util-vserver/chmod.patch b/testing/util-vserver/chmod.patch
new file mode 100644
index 00000000..53861e89
--- /dev/null
+++ b/testing/util-vserver/chmod.patch
@@ -0,0 +1,12 @@
+diff -ru a/Makefile.am b/Makefile.am
+--- a/Makefile.am 2009-09-29 13:48:10.000000000 +0000
++++ b/Makefile.am 2009-09-29 13:50:00.000000000 +0000
+@@ -149,7 +149,7 @@
+ @mkdir -p $$(dirname '$@')
+ @echo "$(SED) -e '...' $*.pathsubst >$*"
+ @$(SED) -e '$(pathsubst_RULES)' '$<' >'$@.tmp'
+- @-chmod --reference='$<' '$@.tmp'
++ @-chmod $$(stat -c %a '$<') '$@.tmp'
+ @if cmp -s '$@.tmp' '$*'; then \
+ echo "... no changes, reusing old version"; \
+ rm -f '$@.tmp'; \
diff --git a/testing/util-vserver/ensc_pathprog.patch b/testing/util-vserver/ensc_pathprog.patch
new file mode 100644
index 00000000..e14c1f6d
--- /dev/null
+++ b/testing/util-vserver/ensc_pathprog.patch
@@ -0,0 +1,14 @@
+diff -ru a/m4/ensc_pathprog.m4 b/m4/ensc_pathprog.m4
+--- a/m4/ensc_pathprog.m4 2009-10-02 17:25:49.000000000 +0000
++++ b/m4/ensc_pathprog.m4 2009-10-02 17:31:28.000000000 +0000
+@@ -61,7 +61,9 @@
+
+ if test "x$5" = x; then
+ if test -h "${$1}"; then
+- $1=`readlink -f "${$1}"`
++ case `readlink "{$1}"` in
++ ../*) $1=`readlink -f "${$1}"`;;
++ esac
+ fi
+ fi
+
diff --git a/testing/util-vserver/validate.patch b/testing/util-vserver/validate.patch
new file mode 100644
index 00000000..081dce5a
--- /dev/null
+++ b/testing/util-vserver/validate.patch
@@ -0,0 +1,10 @@
+diff -ru a/m4/validate.am b/m4/validate.am
+--- a/m4/validate.am 2009-10-02 17:57:03.000000000 +0000
++++ b/m4/validate.am 2009-10-02 17:58:15.000000000 +0000
+@@ -26,5 +26,5 @@
+ .%-up-to-date:
+ @rm -f .*-up-to-date
+ @$(MAKE) -s clean
+- @touch -t 197001020000 '$@'
++ @cp -a Makefile.am '$@'
+ @$(MAKE) -s $(BUILT_SOURCES)