summaryrefslogtreecommitdiffstats
path: root/testing/wine
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-15 22:00:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-15 22:00:24 +0000
commit026984a0c0bdab7eea63727eced374b77bd56bf2 (patch)
tree262f3ed7ca327d7034b1ed121526ef896ee6361f /testing/wine
parent0d747c47869f94391f05b5ae07a8cb94844022c8 (diff)
downloadaports-026984a0c0bdab7eea63727eced374b77bd56bf2.tar.bz2
aports-026984a0c0bdab7eea63727eced374b77bd56bf2.tar.xz
testing/wine: moved from x11
Diffstat (limited to 'testing/wine')
-rw-r--r--testing/wine/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch39
-rw-r--r--testing/wine/APKBUILD29
2 files changed, 68 insertions, 0 deletions
diff --git a/testing/wine/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch b/testing/wine/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch
new file mode 100644
index 00000000..05ac3141
--- /dev/null
+++ b/testing/wine/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch
@@ -0,0 +1,39 @@
+From 0454ace14774654c3670a2a29613bed5039991c5 Mon Sep 17 00:00:00 2001
+From: Roderick Colenbrander <thunderbird2k@gmail.com>
+Date: Thu, 3 Sep 2009 13:51:44 +0200
+Subject: [PATCH] Always adjust the color_shifts pointer when SelectBitmap is called. This fixes a regression in Steam (bug 19916).
+
+---
+ dlls/winex11.drv/bitmap.c | 10 ++++++----
+ 1 files changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/dlls/winex11.drv/bitmap.c b/dlls/winex11.drv/bitmap.c
+index 4d635aa..fee2dbc 100644
+--- a/dlls/winex11.drv/bitmap.c
++++ b/dlls/winex11.drv/bitmap.c
+@@ -110,10 +110,6 @@ HBITMAP CDECL X11DRV_SelectBitmap( X11DRV_PDEVICE *physDev, HBITMAP hbitmap )
+ if (physDev->depth != physBitmap->pixmap_depth)
+ {
+ physDev->depth = physBitmap->pixmap_depth;
+- if(physDev->depth == 1)
+- physDev->color_shifts = NULL;
+- else
+- physDev->color_shifts = &physBitmap->pixmap_color_shifts;
+ wine_tsx11_lock();
+ XFreeGC( gdi_display, physDev->gc );
+ physDev->gc = XCreateGC( gdi_display, physDev->drawable, 0, NULL );
+@@ -122,6 +118,12 @@ HBITMAP CDECL X11DRV_SelectBitmap( X11DRV_PDEVICE *physDev, HBITMAP hbitmap )
+ XFlush( gdi_display );
+ wine_tsx11_unlock();
+ }
++
++ if(physDev->depth == 1)
++ physDev->color_shifts = NULL;
++ else
++ physDev->color_shifts = &physBitmap->pixmap_color_shifts;
++
+ return hbitmap;
+ }
+
+--
+1.6.0.4
diff --git a/testing/wine/APKBUILD b/testing/wine/APKBUILD
new file mode 100644
index 00000000..82ecba1b
--- /dev/null
+++ b/testing/wine/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wine
+pkgver=1.1.36
+pkgrel=0
+pkgdesc="A compatibility layer for running Windows programs"
+url="http://www.winehq.com"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
+ libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison"
+# lcms
+source="http://ibiblio.org/pub/linux/system/emulators/$pkgname/$pkgname-$pkgver.tar.bz2
+ 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch
+ ./configure --prefix=/usr --sysconfdir=/etc --with-x
+ make depend || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make prefix="$pkgdir"/usr install || return 1
+ mkdir -p "$pkgdir"/etc/wine
+}
+md5sums="2afa7846175c7c2ce4c7482aa1d82f0f wine-1.1.36.tar.bz2
+63c4a6aee199039d35e6b57fa505e887 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"