summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:35 +0000
commit59f836786086e0d915e1d73e319d865af2867a14 (patch)
tree496cd4550066b07a2757366336cdf4b13fc9c260 /testing
parent1563fd4b3a2e7d282fb8f472c239d3cb6c2dc6b4 (diff)
downloadaports-59f836786086e0d915e1d73e319d865af2867a14.tar.bz2
aports-59f836786086e0d915e1d73e319d865af2867a14.tar.xz
testing/fetch-crl: removed from stable branch
Diffstat (limited to 'testing')
-rw-r--r--testing/fetch-crl/APKBUILD35
-rw-r--r--testing/fetch-crl/fetch-crl-2.7.0-bb-wget.patch41
2 files changed, 0 insertions, 76 deletions
diff --git a/testing/fetch-crl/APKBUILD b/testing/fetch-crl/APKBUILD
deleted file mode 100644
index cd4f18c1..00000000
--- a/testing/fetch-crl/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=fetch-crl
-pkgver=2.7.0
-pkgrel=1
-pkgdesc="Tool to keep Certificate Revocation Lists (CRLs) up-to-date"
-url="http://dist.eugridpma.info/distribution/util/fetch-crl/"
-license="custom"
-subpackages="$pkgname-doc"
-source="
- http://dist.eugridpma.info/distribution/util/$pkgname/$pkgname-$pkgver.tar.gz
- $pkgname-2.7.0-bb-wget.patch
- "
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- sed -i -e 's:etc/sysconfig:etc/fetch-crl:g' \
- edg-fetch-crl fetch-crl.cron fetch-crl.8
- sed -i -e 's:bin/bash:bin/sh:' fetch-crl.cron
- patch -p1 -i "$srcdir"/$pkgname-2.7.0-bb-wget.patch || return 1
-
-
- _r=$pkgname-$pkgver
- install -m755 -D edg-fetch-crl "$pkgdir"/usr/sbin/fetch-crl
- install -m644 -D fetch-crl.sysconfig "$pkgdir"/etc/fetch-crl/fetch-crl
-
- install -m644 -D fetch-crl.8 "$pkgdir"/usr/share/man/man8/fetch-crl.8
- install -m644 -D README "$pkgdir"/usr/share/doc/$_r/README
- install -m644 -D CHANGES "$pkgdir"/usr/share/doc/$_r/CHANGES
- install -m755 -D fetch-crl.cron "$pkgdir"/usr/share/doc/$_r/fetch-crl.periodic
-}
-
-md5sums="6b0ba042ac3d155f1cd9c7b0baf3c708 fetch-crl-2.7.0.tar.gz
-613e4987db52cbd231cd4d7a46070d74 fetch-crl-2.7.0-bb-wget.patch"
diff --git a/testing/fetch-crl/fetch-crl-2.7.0-bb-wget.patch b/testing/fetch-crl/fetch-crl-2.7.0-bb-wget.patch
deleted file mode 100644
index 48fa7457..00000000
--- a/testing/fetch-crl/fetch-crl-2.7.0-bb-wget.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- fetch-crl-2.7.0/edg-fetch-crl.orig 2009-02-26 08:54:17 +0000
-+++ fetch-crl-2.7.0/edg-fetch-crl 2009-02-26 09:20:27 +0000
-@@ -94,8 +94,8 @@
- allWarnings=no # warnings follow verbosity
-
- # get defaults
--WGET_RETRIES=2
--WGET_TIMEOUT=10
-+#WGET_RETRIES=2
-+#WGET_TIMEOUT=10
- FETCH_CRL_SYSCONFIG="${FETCH_CRL_SYSCONFIG:-/etc/fetch-crl/fetch-crl}"
-
- # specific work-around for incidental filesystem corruption
-@@ -149,7 +149,15 @@
- fi
-
- # add the other default arguments
-- wgetOptions="${wgetOptions} -t $WGET_RETRIES -T $WGET_TIMEOUT "
-+ if [ -n "$WGET_RETRIES" ]; then
-+ wgetOptions="${wgetOptions} -t $WGET_RETRIES "
-+ fi
-+ if [ -n "$WGET_TIMEOUT" ]; then
-+ wgetOptions="${wgetOptions} -T $WGET_TIMEOUT "
-+ fi
-+ if [ -n "$WGET_TIMESTAMPING" ] && [ "$WGET_TIMESTAMPING" != "no" ]; then
-+ wgetOptions="${wgetOptions} -N "
-+ fi
-
- # only add "-q" if the extra options do not have a -v. They are exclusive
- expr match "${wgetAdditionalOptions}" '.*-v' >/dev/null 2>&1
-@@ -175,8 +183,8 @@
- ${rm} -f "${cacheDirectory}/${hash}/pre"
- ${cp} "${cacheDirectory}/${hash}/"* \
- "${cacheDirectory}/${hash}/pre" >/dev/null 2>&1
-- PrintDebug ${wget} ${wgetOptions} -N -P "${cacheDirectory}/${hash}" "${url}"
-- ${wget} ${wgetOptions} -N -P "${cacheDirectory}/${hash}" "${url}"
-+ PrintDebug ${wget} ${wgetOptions} -P "${cacheDirectory}/${hash}" "${url}"
-+ ${wget} ${wgetOptions} -P "${cacheDirectory}/${hash}" "${url}"
- rc=$?
- if [ $rc -ne 0 ]; then
- PrintWarning "RetrieveFileByURL: wget download error $rc for ${url}"