summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:37 +0000
commit960d2ed7af7e7e10e1656907773f6a9c3a708830 (patch)
treec5a0964d05060a41cb8ec147681da307a7bf433f /testing
parent1ba921ec0042bec53700c274d5e92b4a4b73dc22 (diff)
downloadaports-960d2ed7af7e7e10e1656907773f6a9c3a708830.tar.bz2
aports-960d2ed7af7e7e10e1656907773f6a9c3a708830.tar.xz
testing/prosody: removed from stable branch
Diffstat (limited to 'testing')
-rw-r--r--testing/prosody/APKBUILD43
-rw-r--r--testing/prosody/Makefile-0.4.2.patch13
-rw-r--r--testing/prosody/prosody.cfg.lua107
-rw-r--r--testing/prosody/prosody.initd44
-rw-r--r--testing/prosody/prosody.post-install6
-rw-r--r--testing/prosody/prosody.pre-install9
6 files changed, 0 insertions, 222 deletions
diff --git a/testing/prosody/APKBUILD b/testing/prosody/APKBUILD
deleted file mode 100644
index 4f778f2e..00000000
--- a/testing/prosody/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Mika Havela <mika.havela@gmail.com>
-# Maintainer: Mika Havela <mika.havela@gmail.com>
-pkgname=prosody
-pkgver=0.4.2
-pkgrel=2
-pkgdesc="Lua based Jabber/XMPP server"
-url="http://prosody.im/"
-license="MIT"
-depends="lua-socket lua-expat"
-makedepends="lua-dev libidn-dev openssl-dev"
-install="prosody.pre-install prosody.post-install"
-subpackages=""
-source="http://prosody.im/downloads/source/$pkgname-$pkgver.tar.gz
- $pkgname.cfg.lua
- $pkgname.initd
- Makefile-0.4.2.patch
- "
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- patch Makefile "$startdir/Makefile-0.4.2.patch" || return 1
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc/prosody \
- --with-lua=/usr/bin \
- --with-lua-lib=/usr/lib \
- --with-lua-include=/usr/include
-
- make || return 1
- make DESTDIR="$pkgdir" install
-
- install -d "$pkgdir/var/log/prosody" || return 1
- install -d "$pkgdir/var/run/prosody" || return 1
- install -D -m755 "$srcdir"/"$pkgname".initd "$pkgdir"/etc/init.d/"$pkgname"
-
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
-}
-
-md5sums="2669478311b3a67522669acdf03cf85c prosody-0.4.2.tar.gz
-f42039e5a342fe62cd7e491546338aaa prosody.cfg.lua
-c0e647e872e30f71fa03faab189ae287 prosody.initd
-684d033dac42399a245c061c9a374e1b Makefile-0.4.2.patch"
diff --git a/testing/prosody/Makefile-0.4.2.patch b/testing/prosody/Makefile-0.4.2.patch
deleted file mode 100644
index facfa2f9..00000000
--- a/testing/prosody/Makefile-0.4.2.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/prosody-0.4.2/Makefile.org Thu Jun 4 13:44:20 2009
-+++ src/prosody-0.4.2/Makefile Thu Jun 4 13:44:11 2009
-@@ -19,8 +19,8 @@
- install -d $(BIN) $(CONFIG) $(MODULES) $(SOURCE) $(DATA)
- install -d $(CONFIG)/certs
- install -d $(SOURCE)/core $(SOURCE)/net $(SOURCE)/util
-- install ./prosody.install $(BIN)/prosody
-- install ./prosodyctl.install $(BIN)/prosodyctl
-+ install -m755 ./prosody.install $(BIN)/prosody
-+ install -m755 ./prosodyctl.install $(BIN)/prosodyctl
- install -m644 core/* $(SOURCE)/core
- install -m644 net/* $(SOURCE)/net
- install -m644 util/* $(SOURCE)/util
diff --git a/testing/prosody/prosody.cfg.lua b/testing/prosody/prosody.cfg.lua
deleted file mode 100644
index 99df66ad..00000000
--- a/testing/prosody/prosody.cfg.lua
+++ /dev/null
@@ -1,107 +0,0 @@
--- Prosody Configuration File
---
--- If it wasn't already obvious, -- starts a comment, and all text after it on
--- a line is ignored by Prosody.
---
--- The config is split into sections, a global section, and one for each
--- defined host that we serve. You can add as many host sections as you like.
---
--- Lists are written { "like", "this", "one" }
--- Lists can also be of { 1, 2, 3 } numbers, etc.
--- Either commas, or semi-colons; may be used as seperators.
---
--- A table is a list of values, except each value has a name. An example would
--- be:
---
--- logging = { type = "html", directory = "/var/logs", rotate = "daily" }
---
--- Whitespace (that is tabs, spaces, line breaks) is mostly insignificant, so
--- can
--- be placed anywhere
--- that you deem fitting.
---
--- Tip: You can check that the syntax of this file is correct when you have
--- finished by running: luac -p prosody.cfg.lua
--- If there are any errors, it will let you know what and where they are,
--- otherwise it will keep quiet.
---
--- Good luck, and happy Jabbering!
-
--- Global settings go in this section
-Host "*"
- -- This is the list of modules Prosody will load on startup.
- -- It looks for mod_modulename.lua in the plugins folder, so make sure that
- -- exists too.
- modules_enabled = {
- -- Generally required
- "roster"; -- Allow users to have a roster. Recommended ;)
- "saslauth"; -- Authentication for clients and servers. Recommended
- -- if you want to log in.
- "tls"; -- Add support for secure TLS on c2s/s2s connections
- "dialback"; -- s2s dialback support
- "disco"; -- Service discovery
-
- -- Not essential, but recommended
- "private"; -- Private XML storage (for room bookmarks, etc.)
- "vcard"; -- Allow users to set vCards
-
- -- Nice to have
- "legacyauth"; -- Legacy authentication. Only used by some old
- -- clients and bots.
- "version"; -- Replies to server version requests
- "uptime"; -- Report how long server has been running
- "time"; -- Let others know the time here on this server
- "ping"; -- Replies to XMPP pings with pongs
-
- -- Required for daemonizing and logging
- "posix"; -- POSIX functionality, sends server to background,
- -- enables syslog, etc.
-
- -- Other specific functionality
- "register"; -- Allow users to register on this server using a
- -- client
- --"console"; -- telnet to port 5582 (needs console_enabled = true)
- --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
- --"httpserver"; -- Serve static files from a directory over HTTP
- }
-
- -- These are the SSL/TLS-related settings. If you don't want to use
- -- SSL/TLS, you may comment or remove this
- --ssl = {
- -- key = "/etc/prosody/certs/localhost.key";
- -- certificate = "/etc/prosody/certs/localhost.cert";
- --}
-
- log = {
- -- Log all error messages to prosody.err
- { levels = { min = "error" }, to = "file", timestamps = true,
- filename = "/var/log/prosody/prosody.err" };
- -- Log everything of level "info" and higher (that is, all except
- -- "debug" messages) to prosody.log
- { levels = { min = "info" }, to = "file", timestamps = true,
- filename = "/var/log/prosody/prosody.log" };
- }
-
- -- Required for proper daemonization support
- pidfile = "/var/run/prosody/prosody.pid"
-
--- This allows clients to connect to localhost. No harm in it.
-Host "localhost"
-
--- Section for example.com
--- (replace example.com with your domain name)
-Host "example.com"
- -- Assign this host a certificate for TLS, otherwise it would use the one
- -- set in the global section (if any).
- -- Note that old-style SSL on port 5223 only supports one certificate, and
- -- will always use the global one.
- --ssl = {
- -- key = "/etc/prosody/certs/example.com.key";
- -- certificate = "/etc/prosody/certs/example.com.crt";
- --}
-
- enabled = false -- This will disable the host, preserving the config, but
- -- denying connections
-
--- Set up a MUC (multi-user chat) room server on conference.localhost:
-Component "conference.localhost" "muc"
diff --git a/testing/prosody/prosody.initd b/testing/prosody/prosody.initd
deleted file mode 100644
index 2749d09c..00000000
--- a/testing/prosody/prosody.initd
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/sbin/runscript
-
-# Sample init.d file for alpine linux.
-
-NAME=prosody
-DAEMON=/usr/bin/$NAME
-
-depend() {
- need net
- after firewall
-}
-
-start() {
- ebegin "Starting ${NAME}"
- /usr/bin/prosodyctl start
-# start-stop-daemon --start --quiet --background \
-# --make-pidfile --pidfile /var/run/${NAME}/${NAME}.pid \
-# --chuid ${USER}:${GROUP} \
-# --exec ${DAEMON} -- ${OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${NAME}"
- /usr/bin/prosodyctl stop
-# start-stop-daemon --stop --quiet \
-# --exec ${DAEMON} \
-# --pidfile /var/run/${NAME}/${NAME}.pid \
- eend $?
-}
-
-reload() {
- ebegin "Reloading ${NAME}"
- if ! service_started "${NAME}" ; then
- eend 1 "${NAME} is not started"
- return 1
- fi
- /usr/bin/prosodyctl stop
- /usr/bin/prosodyctl start
-# start-stop-daemon --stop --oknodo --signal HUP \
-# --exec ${DAEMON} --pidfile /var/run/${NAME}/${NAME}.pid
- eend $?
-}
-
diff --git a/testing/prosody/prosody.post-install b/testing/prosody/prosody.post-install
deleted file mode 100644
index 2f8f69cd..00000000
--- a/testing/prosody/prosody.post-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-chown prosody:prosody var/lib/prosody
-chown prosody:prosody var/log/prosody
-chown prosody:prosody var/run/prosody
-
diff --git a/testing/prosody/prosody.pre-install b/testing/prosody/prosody.pre-install
deleted file mode 100644
index db63efa1..00000000
--- a/testing/prosody/prosody.pre-install
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-user=prosody
-home=/var/lib/prosody
-adduser -h $home -s /bin/false -D $user 2>/dev/null
-mkdir -p $home
-chown $user:$user $home
-exit 0
-