summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-03 10:07:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-03 10:53:41 +0000
commitc86b5e759c3fbd2f84d1b2d6d975ede2f2513cda (patch)
treeeef4523f72d8603d19487e230d1cd464d9a482ff /testing
parent5eba4f983fb9c9250af0969ccd4347c8f945fbb9 (diff)
downloadaports-c86b5e759c3fbd2f84d1b2d6d975ede2f2513cda.tar.bz2
aports-c86b5e759c3fbd2f84d1b2d6d975ede2f2513cda.tar.xz
testing/minicom: use package() function
(cherry picked from commit 078cff5be912f1db1c99cdf3ca46e287fb876483)
Diffstat (limited to 'testing')
-rw-r--r--testing/minicom/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/testing/minicom/APKBUILD b/testing/minicom/APKBUILD
index 5d0c638e..c419a9dc 100644
--- a/testing/minicom/APKBUILD
+++ b/testing/minicom/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=minicom
pkgver=2.3
-pkgrel=0
+pkgrel=1
pkgdesc="menu driven communications program for terminals"
url="http://alioth.debian.org/projects/minicom"
license="GPL"
@@ -12,17 +12,20 @@ install=
subpackages="$pkgname-doc"
source="http://alioth.debian.org/frs/download.php/2332/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--without-libintl-prefix
make || return 1
- make DESTDIR="$pkgdir" install
+}
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
}
md5sums="0ebe7a91898384ca906787cc4e2c3f25 minicom-2.3.tar.gz"