summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-03 10:59:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-03 10:59:59 +0000
commit0b78fecab0f11c941c1f2acc0381acfe879369c0 (patch)
tree2eb80c9ebaabce9fde7f9fa3bef26dd305836c48 /testing
parentc673986f828a016059d5f1bbadea2e14d95fe2c2 (diff)
downloadaports-0b78fecab0f11c941c1f2acc0381acfe879369c0.tar.bz2
aports-0b78fecab0f11c941c1f2acc0381acfe879369c0.tar.xz
testing/vlc: removed
needs nptl
Diffstat (limited to 'testing')
-rw-r--r--testing/vlc/APKBUILD90
-rw-r--r--testing/vlc/uclibc.patch65
2 files changed, 0 insertions, 155 deletions
diff --git a/testing/vlc/APKBUILD b/testing/vlc/APKBUILD
deleted file mode 100644
index d28ddf07..00000000
--- a/testing/vlc/APKBUILD
+++ /dev/null
@@ -1,90 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=vlc
-pkgver=1.0.0
-pkgrel=0
-pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
-url="http://www.videolan.org/vlc/"
-license="GPL-2"
-subpackages="$pkgname-dev $pkgname-doc"
-#depends="libnotify a52dec fluidsynth zvbi libdvbpsi lirc-utils libdca hal
-# libproxy sdl_image libdvdnav>=4.1.3 lua libxv libv4l libcddb smbclient
-# libmatroska taglib sysfsutils libmpcdec ffmpeg>=0.5 libshout libmad
-# qt fribidi libmpeg2 libmodplug avahi ttf-dejavu"
-depends="ttf-dejavu"
-makedepends="
- a52dec-dev
- alsa-lib-dev
- dbus-dev
- ffmpeg-dev
- fribidi-dev
- gtk+-dev
- libgcrypt-dev
- libice-dev
- libiconv-dev
- libmad-dev
- libmpeg2-dev
- libnotify-dev
- libogg-dev
- libsm-dev
- libx11-dev
- libxext-dev
- libxv-dev
- lua-dev
- mesa-dev
- pkgconfig
- sdl-dev
- sysfsutils-dev
- x264-dev
- "
-source="http://download.videolan.org/pub/videolan/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2
- uclibc.patch
- "
-
-build ()
-{
- cd "$srcdir"/$pkgname-$pkgver
- sed -i -e 's:/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf:/usr/share/fonts/TTF/DejaVuSerif-Bold.ttf:' modules/misc/freetype.c
-
- patch -p1 < ../uclibc.patch || return 1
- export CFLAGS="$CFLAGS -D_GNU_SOURCE"
-
- ./configure --prefix=/usr \
- --disable-mmx \
- --disable-nls \
- --disable-optimizations \
- --disable-qt4 --disable-skins2 \
- --disable-rpath \
- --enable-httpd \
- --enable-realrtsp \
- --enable-sout \
- --enable-vlm \
- || return 1
-
-# --enable-dvdread \
-# --enable-dvdnav \
-# --enable-qt4 \
-# --enable-faad \
-# --enable-skins2 \
-# --enable-dvb \
-# --enable-v4l \
-# --enable-theora \
-# --enable-flac \
-# --enable-snapshot \
-# --enable-hal \
-# --enable-dbus \
-# --enable-dbus-control \
-# --enable-lirc \
-# --enable-shout \
-# --enable-pvr \
-
- make || return 1
- make DESTDIR="$pkgdir"/ install || return 1
- for res in 16 32 48 128; do
- install -D -m644 share/vlc${res}x${res}.png \
- "$pkgdir"/usr/share/icons/hicolor/${res}x${res}/apps/vlc.png || return 1
- done
- rm -rf "$pkgdir"/usr/lib/mozilla
-}
-
-md5sums="fc78904ab5fa73f518d8fe4e852e7f67 vlc-1.0.0.tar.bz2
-2a16bf6c14a94f41490872aa189db755 uclibc.patch"
diff --git a/testing/vlc/uclibc.patch b/testing/vlc/uclibc.patch
deleted file mode 100644
index f71b189a..00000000
--- a/testing/vlc/uclibc.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- a/src/misc/linux_specific.c 2009-07-08 09:29:41.000000000 +0000
-+++ b/src/misc/linux_specific.c 2009-07-08 09:30:47.000000000 +0000
-@@ -72,14 +72,14 @@
- }
- #endif
-
--#ifdef __GLIBC__
-+#if defined(__GLIBC__) && !defined(__UCLIBC__)
- # include <gnu/libc-version.h>
- # include <stdlib.h>
- #endif
-
- void system_Init (libvlc_int_t *libvlc, int *argc, const char *argv[])
- {
--#ifdef __GLIBC__
-+#if defined(__GLIBC__) && !defined(__UCLIBC__)
- const char *glcv = gnu_get_libc_version ();
-
- /* gettext in glibc 2.5-2.7 is not thread-safe. LibVLC keeps crashing,
---- a/src/control/vlm.c 2009-07-09 09:21:55.000000000 +0000
-+++ b/src/control/vlm.c 2009-07-09 09:22:24.000000000 +0000
-@@ -21,6 +21,10 @@
- * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston MA 02110-1301, USA.
- *****************************************************************************/
-
-+#ifdef HAVE_CONFIG_H
-+# include "config.h"
-+#endif
-+
- #include <vlc/libvlc.h>
- #include <vlc/libvlc_vlm.h>
- #include <vlc_es.h>
---- a/src/misc/mtime.c 2009-07-09 11:57:46.000000000 +0000
-+++ b/src/misc/mtime.c 2009-07-09 13:48:16.000000000 +0000
-@@ -78,7 +78,7 @@
- # define _POSIX_CLOCK_SELECTION (-1)
- #endif
-
--# if (_POSIX_CLOCK_SELECTION < 0)
-+# if (_POSIX_CLOCK_SELECTION < 0) || defined(__UCLIBC__)
- /*
- * We cannot use the monotonic clock is clock selection is not available,
- * as it would screw vlc_cond_timedwait() completely. Instead, we have to
---- a/src/misc/threads.c 2009-07-09 13:54:08.000000000 +0000
-+++ b/src/misc/threads.c 2009-07-09 13:54:32.000000000 +0000
-@@ -474,7 +474,7 @@
- /* Fairly outdated POSIX support (that was defined in 2001) */
- # define _POSIX_CLOCK_SELECTION (-1)
- # endif
--# if (_POSIX_CLOCK_SELECTION >= 0)
-+# if (_POSIX_CLOCK_SELECTION >= 0) && !defined(__UCLIBC__)
- /* NOTE: This must be the same clock as the one in mtime.c */
- pthread_condattr_setclock (&attr, CLOCK_MONOTONIC);
- # endif
---- a/modules/stream_filter/decomp.c 2009-07-09 14:10:09.000000000 +0000
-+++ b/modules/stream_filter/decomp.c 2009-07-09 14:11:37.000000000 +0000
-@@ -28,7 +28,7 @@
- #include <vlc_network.h>
- #include <assert.h>
- #include <unistd.h>
--#ifndef _POSIX_SPAWN
-+#if !defined(_POSIX_SPAWN) || defined(__UCLIBC__)
- # define _POSIX_SPAWN (-1)
- #endif
- #include <fcntl.h>