summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-03 07:46:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-03 07:48:04 +0000
commit5eba4f983fb9c9250af0969ccd4347c8f945fbb9 (patch)
tree0c13ef0513834aab6e36346535cacd5e3b4890c6 /testing
parent6282f90419b0348961da6e5e3167f46552ab2e9f (diff)
downloadaports-5eba4f983fb9c9250af0969ccd4347c8f945fbb9.tar.bz2
aports-5eba4f983fb9c9250af0969ccd4347c8f945fbb9.tar.xz
main/fprobe: move from testing
(cherry picked from commit 8a1df176ce5a4d220752e4c4165992268e5922d2)
Diffstat (limited to 'testing')
-rw-r--r--testing/fprobe/APKBUILD36
-rw-r--r--testing/fprobe/fprobe.confd70
-rw-r--r--testing/fprobe/fprobe.initd40
3 files changed, 0 insertions, 146 deletions
diff --git a/testing/fprobe/APKBUILD b/testing/fprobe/APKBUILD
deleted file mode 100644
index 824129af..00000000
--- a/testing/fprobe/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
-pkgname=fprobe
-pkgver=1.1
-pkgrel=2
-pkgdesc="libpcap-based tool that collect network traffic"
-url="http://fprobe.sourceforge.net/"
-license="GPL"
-depends=
-makedepends="libpcap-dev"
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
-$pkgname.initd
-$pkgname.confd"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install
-
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-md5sums="65850d0470078269b33eee58cba77ac2 fprobe-1.1.tar.bz2
-41810a73503624de2c27809e34ed80b4 fprobe.initd
-ba9c9327456e4db897b60481705df282 fprobe.confd"
diff --git a/testing/fprobe/fprobe.confd b/testing/fprobe/fprobe.confd
deleted file mode 100644
index 1c444f55..00000000
--- a/testing/fprobe/fprobe.confd
+++ /dev/null
@@ -1,70 +0,0 @@
-# Config file for /etc/init.d/fprobe
-
-# Do we want the interface in promiscous mode [yes/no]
-#PROMISC=no
-
-# Interface
-IFACE=eth0
-
-# If configured, only capture packets matching this tcpdump expression
-#FILTER=""
-
-# Flow state timers
-#TIMER_EXPIRED=5
-#TIMER_FRAGMENTED=30
-#TIMER_IDLE=60
-#TIMER_ACTIVE=300
-
-# This is the default and should be left unless you know what you are doing
-#FLOW_VER=5
-
-# local ip. if configured fprobe will use this as the source IP for sending ALL flow data
-# If you want to specify a specific source address per collecter, customize it below
-#LOCALIP=
-
-# SNMP iface id
-SNMP_IFACE="${IFACE//eth}"
-
-# Maximum number of concurrent flows to track
-# using a specified amount of memory
-#MEMBULK=10000
-#MEMLIMIT=
-
-# Pending queue
-#PENDING=100
-
-# Kernel capture buffer size (kB)
-#KERNBUF=1024
-
-# Realtime priority [0=disabled, 1..99]
-#RTPRIO=0
-
-# Delay N nanoseconds after each B bytes
-#DELAY="0:0"
-
-# How much of the start of each packet to grab
-#SNAPLEN=256
-
-# chroot() to this location after startup
-CHROOT="/var/empty"
-
-# User to run as. must have perms to the pidfile directory /var/run/fprobe/
-USER=nobody
-
-# logging level for syslog (0=EMERG, ..., 6=INFO, 7=DEBUG)
-#LOGLEVEL=6
-
-# If you want to run multiple instances of fprobe,
-# You MUST set this variable to a unique INTEGER for each one!
-PIDFILE_ID=''
-
-# remote ip. this is where we send flows
-REMOTEIP=127.0.0.1
-# port to listen on
-PORT=2055
-# Collector type, see the manpage for valid types
-TYPE=''
-
-# If you want multiple collectors, just specify each one here
-COLLECTORS="${REMOTEIP}:${PORT}/${LOCALIP}/${TYPE}"
-
diff --git a/testing/fprobe/fprobe.initd b/testing/fprobe/fprobe.initd
deleted file mode 100644
index a14f1e6b..00000000
--- a/testing/fprobe/fprobe.initd
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
- after firewall
-}
-
-BIN=/usr/sbin/fprobe
-PIDFILE_EXTRA=""
-[ -n "$PIDFILE_ID" ] && PIDFILE_EXTRA="[$PIDFILE_ID]"
-PIDFILE="/var/run/fprobe$PIDFILE_EXTRA.pid"
-
-start() {
- ebegin "Starting fprobe"
- local OPTS=""
- [ "${PROMISC}" == "yes" ] || OPTS="${OPTS} -p"
- [ -n "${FILTER}" ] && OPTS="${OPTS} -f '${FILTER}'"
- for optname in i:IFACE s:TIMER_EXPIRED g:TIME_FRAGMENTED d:TIMER_IDLE \
- e:TIMER_ACTIVE n:FLOW_VER a:LOCALIP x:SNMP_IFACE b:MEMBULK \
- m:MEMLIMIT q:PENDING B:KERNBUF r:RTPRIO t:DELAY S:SNAPLEN \
- c:CHROOT u:USER v:LOGLEVEL ; do
- opt="${optname/:*}" optvar="${optname/*:}"
- eval optvalue="\$$optvar"
- [ -n "$optvalue" ] && OPTS="${OPTS} -${opt} ${optvalue}"
- done
- OPTS="${OPTS} -l 1:${PIDFILE_ID} ${COLLECTORS}"
- start-stop-daemon --start --exec $BIN \
- --pidfile ${PIDFILE} \
- -- ${OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping fprobe"
- start-stop-daemon --stop --quiet --exec $BIN \
- --pidfile ${PIDFILE}
- eend $?
-}