summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-28 07:53:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-28 07:53:51 +0000
commit6a8740715b7d5816981260309359c362ca989261 (patch)
tree4f943917c88de4261fcaee3a96a30a321759256f /testing
parent01912d7bb7fbe5173783503c9474a6c8ef624bc8 (diff)
downloadaports-6a8740715b7d5816981260309359c362ca989261.tar.bz2
aports-6a8740715b7d5816981260309359c362ca989261.tar.xz
testing/cherokee: upgrade to 0.99.41
Diffstat (limited to 'testing')
-rw-r--r--testing/cherokee/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/testing/cherokee/APKBUILD b/testing/cherokee/APKBUILD
index 83e04bd2..47a7d43a 100644
--- a/testing/cherokee/APKBUILD
+++ b/testing/cherokee/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: Mika Havela <mika.havela@gmail.com>
pkgname=cherokee
-pkgver=0.99.39
+pkgver=0.99.41
pkgrel=0
pkgdesc="A very fast, flexible and easy to configure Web Server"
url="http://www.cherokee-project.com/"
@@ -15,20 +15,24 @@ source="http://www.cherokee-project.com/download/0.99/${pkgver}/${pkgname}-${pkg
cherokee.confd
"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
-
+ cd "$_builddir"
./configure --prefix=/usr \
--localstatedir=/var \
--sysconfdir=/etc \
--with-wwwroot=/var/www
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-md5sums="2e9694268eda387489b10b2e237e291a cherokee-0.99.39.tar.gz
+md5sums="388affc0636aca802ec46cea4ebb8d08 cherokee-0.99.41.tar.gz
4180dbb6701f928054079aa1e3bd5ebc cherokee.initd
bd6a840f72c630ce1eaabe058097584f cherokee.confd"