summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-02 08:58:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-02 08:58:31 +0000
commit7f4b6f87039a8d6a59ee2a7dd614d2410d519530 (patch)
treeb760062600941cc69d70dcf59d5b580561e6d62d /testing
parent1b6a10374fbd4e77b065b66c5e0890111468bd1a (diff)
downloadaports-7f4b6f87039a8d6a59ee2a7dd614d2410d519530.tar.bz2
aports-7f4b6f87039a8d6a59ee2a7dd614d2410d519530.tar.xz
testing/freeswitch: moved from unstable
fixes #257
Diffstat (limited to 'testing')
-rw-r--r--testing/freeswitch/APKBUILD53
-rw-r--r--testing/freeswitch/freeswitch.initd19
-rwxr-xr-xtesting/freeswitch/freeswitch.install15
-rw-r--r--testing/freeswitch/modules.conf75
4 files changed, 162 insertions, 0 deletions
diff --git a/testing/freeswitch/APKBUILD b/testing/freeswitch/APKBUILD
new file mode 100644
index 00000000..293678c7
--- /dev/null
+++ b/testing/freeswitch/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+pkgname=freeswitch
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="A communications platform written in C from the ground up"
+url="http://www.freeswitch.org"
+license="GPL"
+depends=""
+makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev
+ autoconf automake libtool"
+install=
+subpackages="$pkgname-dev"
+source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
+ modules.conf
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cp -f "$srcdir/modules.conf" modules.conf || return 1
+
+ # i think our max cmd len is 32768
+ # by specifying it here we save our selves from some CPU cycles
+ export lt_cv_sys_max_cmd_len=8192
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/freeswitch \
+ --with-modinstdir=/usr/lib/freeswitch \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+
+ # check how/when parallel builds are fixed here:
+ # http://jira.freeswitch.org/browse/FSBUILD-6
+
+ # build the libs and prerequisites in parallel first
+ make libs/apr/libapr-1.la \
+ libs/apr-util/libaprutil-1.la \
+ libs/speex/libspeex/libspeexdsp.la \
+ libs/sqlite/libsqlite3.la \
+ libs/pcre/libpcre.la \
+ libs/srtp/libsrtp.la \
+ src/include/switch_version.h
+
+ # then the rest should build in parallel too
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install
+
+ # TODO: make and test init.d scripts
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="86e34bdd8cc027d71772cb0dc51388da freeswitch-1.0.4.tar.gz
+c05f2356be159e99b3845f5260a33599 modules.conf"
diff --git a/testing/freeswitch/freeswitch.initd b/testing/freeswitch/freeswitch.initd
new file mode 100644
index 00000000..34f44139
--- /dev/null
+++ b/testing/freeswitch/freeswitch.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+
+NAME=freeswitch
+USER=freeswitch
+DAEMON=/usr/bin/freeswitch
+OPTIONS_START="-u $USER -g $GROUP -nc"
+OPTIONS_STOP="-stop"
+
+start() {
+ ebegin "Starting $NAME"
+ $DAEMON $OPTIONS_START
+ eend 0
+ }
+
+stop() {
+ ebegin "Stopping $NAME"
+ $DAEMON $OPTIONS_STOP
+ eend 0
+ }
diff --git a/testing/freeswitch/freeswitch.install b/testing/freeswitch/freeswitch.install
new file mode 100755
index 00000000..0507fe53
--- /dev/null
+++ b/testing/freeswitch/freeswitch.install
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+case "$1" in
+ pre_install)
+ adduser -h /dev/null -s /bin/false -D freeswitch 2>/dev/null
+ ;;
+ post_install)
+ chown -R freeswitch:freeswitch /etc/freeswitch/
+ ;;
+ post_deinstall)
+ deluser freeswitch
+ delgroup freeswitch
+ ;;
+esac
+
diff --git a/testing/freeswitch/modules.conf b/testing/freeswitch/modules.conf
new file mode 100644
index 00000000..c6f5a05d
--- /dev/null
+++ b/testing/freeswitch/modules.conf
@@ -0,0 +1,75 @@
+loggers/mod_console
+loggers/mod_logfile
+loggers/mod_syslog
+applications/mod_commands
+applications/mod_conference
+applications/mod_dptools
+applications/mod_enum
+applications/mod_fifo
+#applications/mod_fax
+applications/mod_voicemail
+#applications/mod_lcr
+applications/mod_limit
+applications/mod_expr
+applications/mod_esf
+#applications/mod_easyroute
+applications/mod_fsv
+#applications/mod_soundtouch
+#applications/mod_rss
+#applications/mod_snom
+#applications/mod_vmd
+#asr_tts/mod_flite
+#asr_tts/mod_pocketsphinx
+#asr_tts/mod_cepstral
+codecs/mod_g723_1
+codecs/mod_amr
+#codecs/mod_amrwb
+codecs/mod_g729
+codecs/mod_h26x
+codecs/mod_voipcodecs
+codecs/mod_ilbc
+codecs/mod_speex
+#codecs/mod_siren
+#codecs/mod_celt
+#codecs/mod_dahdi_codec
+#dialplans/mod_dialplan_directory
+dialplans/mod_dialplan_xml
+dialplans/mod_dialplan_asterisk
+#directories/mod_ldap
+#endpoints/mod_dingaling
+endpoints/mod_iax
+#endpoints/mod_portaudio
+endpoints/mod_sofia
+endpoints/mod_loopback
+#endpoints/mod_alsa
+#endpoints/mod_opal
+#../../libs/openzap/mod_openzap
+#event_handlers/mod_event_multicast
+event_handlers/mod_event_socket
+event_handlers/mod_cdr_csv
+#event_handlers/mod_radius_cdr
+formats/mod_native_file
+formats/mod_sndfile
+#formats/mod_shout
+formats/mod_local_stream
+formats/mod_tone_stream
+#languages/mod_python
+#languages/mod_spidermonkey
+#languages/mod_spidermonkey_teletone
+#languages/mod_spidermonkey_core_db
+#languages/mod_spidermonkey_socket
+#languages/mod_spidermonkey_odbc
+languages/mod_lua
+#languages/mod_perl
+#languages/mod_yaml
+#xml_int/mod_xml_rpc
+#xml_int/mod_xml_curl
+#xml_int/mod_xml_cdr
+#xml_int/mod_xml_ldap
+say/mod_say_en
+#say/mod_say_de
+#say/mod_say_es
+#say/mod_say_fr
+#say/mod_say_it
+#say/mod_say_nl
+#say/mod_say_zh