summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-08 15:08:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-08 15:08:53 +0000
commitd4ea89d5e98e02602acac62441cc337afca9e3ce (patch)
tree2ea9ed47378cf2a2b80f2d7b2d57ffe86c8f03f1 /testing
parent396fcaf172906d08ad4d85cc403608b64e2885a9 (diff)
downloadaports-d4ea89d5e98e02602acac62441cc337afca9e3ce.tar.bz2
aports-d4ea89d5e98e02602acac62441cc337afca9e3ce.tar.xz
x11/xfce4-wavelan-plugin: moved from testing
it works
Diffstat (limited to 'testing')
-rw-r--r--testing/xfce4-wavelan-plugin/APKBUILD32
-rw-r--r--testing/xfce4-wavelan-plugin/tooltip.diff19
2 files changed, 0 insertions, 51 deletions
diff --git a/testing/xfce4-wavelan-plugin/APKBUILD b/testing/xfce4-wavelan-plugin/APKBUILD
deleted file mode 100644
index 27176f01..00000000
--- a/testing/xfce4-wavelan-plugin/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=xfce4-wavelan-plugin
-pkgver=0.5.5
-pkgrel=0
-pkgdesc="plugin to monitor wifi connectivity for the Xfce4 panel"
-url="http://goodies.xfce.org/projects/panel-plugins/xfce4-wavelan-plugin/"
-license="custom"
-depends=
-makedepends="pkgconfig xfce4-panel-dev intltool libsm-dev"
-source="http://goodies.xfce.org/releases/$pkgname/$pkgname-$pkgver.tar.bz2
- tooltip.diff"
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- patch -Np1 -i "$srcdir"/tooltip.diff || return 1
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --disable-static
- make || return 1
-}
-
-package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install || return 1
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
-}
-
-md5sums="1fa00ad9f24cc29536cb7622016c6a5e xfce4-wavelan-plugin-0.5.5.tar.bz2
-923b1f2bf2d26cf01f784b6194f64d93 tooltip.diff"
diff --git a/testing/xfce4-wavelan-plugin/tooltip.diff b/testing/xfce4-wavelan-plugin/tooltip.diff
deleted file mode 100644
index f180f569..00000000
--- a/testing/xfce4-wavelan-plugin/tooltip.diff
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naur xfce4-wavelan-plugin-0.5.5.old/panel-plugin/wavelan.c xfce4-wavelan-plugin-0.5.5/panel-plugin/wavelan.c
---- xfce4-wavelan-plugin-0.5.5.old/panel-plugin/wavelan.c 2009-10-09 14:42:54.427988584 +0200
-+++ xfce4-wavelan-plugin-0.5.5/panel-plugin/wavelan.c 2009-10-09 14:45:24.351280223 +0200
-@@ -199,6 +199,14 @@
- if ((wavelan->device = wi_open(wavelan->interface)) != NULL) {
- /* register the update timer */
- TRACE ("Opened device");
-+ /* reduce the default tooltip timeout to be smaller than the update interval otherwise
-+ * we won't see tooltips on GTK 2.16 or newer */
-+ GtkSettings *settings;
-+ settings = gtk_settings_get_default();
-+ if (g_object_class_find_property(G_OBJECT_GET_CLASS(settings), "gtk-tooltip-timeout"))
-+ g_object_set(settings, "gtk-tooltip-timeout",
-+ 250 - 10, NULL);
-+
- wavelan->timer_id = g_timeout_add(250, wavelan_timer, wavelan);
- }
- }
-