summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-14 10:10:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-14 10:10:39 +0000
commiteabee94e6ef33c55782619f4591e1a1ed33356a3 (patch)
treed1c761ac181969880a3d79da4090e290feaf9e35 /testing
parentdd0022d637b0a21f616550bca17979d8370eaea5 (diff)
downloadaports-eabee94e6ef33c55782619f4591e1a1ed33356a3.tar.bz2
aports-eabee94e6ef33c55782619f4591e1a1ed33356a3.tar.xz
testing/uvncrepeater: new aport
VNC repeater based on ultravnc repeater http://koti.mbnet.fi/jtko/
Diffstat (limited to 'testing')
-rw-r--r--testing/uvncrepeater/APKBUILD43
-rw-r--r--testing/uvncrepeater/uvncrepeater.confd4
-rw-r--r--testing/uvncrepeater/uvncrepeater.initd32
-rw-r--r--testing/uvncrepeater/uvncrepeater.pre-install5
4 files changed, 84 insertions, 0 deletions
diff --git a/testing/uvncrepeater/APKBUILD b/testing/uvncrepeater/APKBUILD
new file mode 100644
index 00000000..c5636610
--- /dev/null
+++ b/testing/uvncrepeater/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor:
+# Maintainer:
+pkgname=uvncrepeater
+pkgver=014
+pkgrel=0
+pkgdesc="VNC repeater based on ultravnc repeater"
+url="http://koti.mbnet.fi/jtko/"
+license="GPL-2"
+depends=
+makedepends=
+install="$pkgname.pre-install"
+subpackages=
+source="http://koti.mbnet.fi/jtko/uvncrepeater/repeater$pkgver.zip
+ uvncrepeater.confd
+ uvncrepeater.initd"
+
+_builddir="$srcdir"/Ver$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # respect our CXX and CFLAGS
+ sed -i -e 's/g++/$(CXX)/g' \
+ -e "/^CFLAGS/d" Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 repeater "$pkgdir"/usr/bin/repeater
+ install -Dm644 uvncrepeater.ini "$pkgdir"/etc/uvncrepeater.ini
+ install -Dm755 "$srcdir"/uvncrepeater.initd \
+ "$pkgdir"/etc/init.d/uvncrepeater
+ install -Dm755 "$srcdir"/uvncrepeater.confd \
+ "$pkgdir"/etc/conf.d/uvncrepeater
+}
+
+md5sums="3005ebbb2f9442cbea4cbcaa71925dbf repeater014.zip
+9a789921340c123ea1c35d7e64563c64 uvncrepeater.confd
+a9c614f7bfeef4f68db7cd9d87a6bdf6 uvncrepeater.initd"
diff --git a/testing/uvncrepeater/uvncrepeater.confd b/testing/uvncrepeater/uvncrepeater.confd
new file mode 100644
index 00000000..1d0b3ce8
--- /dev/null
+++ b/testing/uvncrepeater/uvncrepeater.confd
@@ -0,0 +1,4 @@
+# redirect debug logging to this file
+#
+# uvncrepeater_logfile=/var/log/uvncrepeater.log
+
diff --git a/testing/uvncrepeater/uvncrepeater.initd b/testing/uvncrepeater/uvncrepeater.initd
new file mode 100644
index 00000000..655ade92
--- /dev/null
+++ b/testing/uvncrepeater/uvncrepeater.initd
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+
+# Sample init.d file for alpine linux.
+
+name=repeater
+daemon=/usr/bin/$name
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting VNC ${name}"
+ start-stop-daemon --start --quiet \
+ --pidfile /var/run/${name}.pid \
+ --make-pidfile --background \
+ --wait ${uvncrepeater_wait:-500} \
+ --stderr ${uvncrepeater_logfile:-/dev/null} \
+ --stdout /dev/null \
+ --exec ${daemon} -- /etc/uvncrepeater.ini
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping VNC ${name}"
+ start-stop-daemon --stop --quiet \
+ --pidfile /var/run/$name.pid \
+ --exec ${daemon}
+ eend $?
+}
+
diff --git a/testing/uvncrepeater/uvncrepeater.pre-install b/testing/uvncrepeater/uvncrepeater.pre-install
new file mode 100644
index 00000000..2e1e6730
--- /dev/null
+++ b/testing/uvncrepeater/uvncrepeater.pre-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+adduser -D -S uvncrep 2>/dev/null
+exit 0
+