summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-12-14 13:33:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-12-14 13:33:10 +0000
commit6b201dfcd600db5a897710703d4aec83e9b6a0c9 (patch)
treeae9084eddf23d39a69e118c3b189b20025e019c9 /testing
parentce09110732b963e07bb8edd1166ff946c333ebe3 (diff)
downloadaports-6b201dfcd600db5a897710703d4aec83e9b6a0c9.tar.bz2
aports-6b201dfcd600db5a897710703d4aec83e9b6a0c9.tar.xz
main/mpd: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/mpd/APKBUILD49
-rw-r--r--testing/mpd/mpd.confd7
-rw-r--r--testing/mpd/mpd.initd44
-rw-r--r--testing/mpd/mpd.pre-install4
4 files changed, 0 insertions, 104 deletions
diff --git a/testing/mpd/APKBUILD b/testing/mpd/APKBUILD
deleted file mode 100644
index 461f3475..00000000
--- a/testing/mpd/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Contributor: Sebastian Wicki <gandro@gmx.net>
-# Maintainer: Natanael Copa <natanael.copa@gmail.com>
-pkgname=mpd
-pkgver=0.15.6
-pkgrel=0
-pkgdesc="Music daemon that plays MP3, FLAC, and Ogg Vorbis files"
-url="http://musicpd.org"
-pkgusers="mpd"
-pkggroups="mpd audio"
-license="GPL2"
-depends=
-makedepends="pkgconfig lame-dev glib-dev curl-dev libao-dev libmad-dev flac-dev
- libogg-dev faad2-dev libid3tag-dev libvorbis-dev alsa-lib-dev
- libsamplerate-dev"
-install="$pkgname.pre-install"
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/project/musicpd/mpd/${pkgver}/mpd-${pkgver}.tar.bz2
- mpd.initd
- mpd.confd
- "
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- make || return 1
- make DESTDIR="$pkgdir" install
-
- #provide a config that works by default
- install -d "$pkgdir"/etc
- sed -e 's:\#pid_file.*:pid_file\t\t/var/run/mpd/mpd.pid:' \
- -e 's:\#user.*:user\t\tmpd:' \
- -e 's:\#log_file.*:log_file\t\t/var/log/mpd/mpd.log:' \
- doc/mpdconf.example > "$pkgdir"/etc/mpd.conf
-
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
- install -d -g audio -o mpd -m775 \
- "$pkgdir"/var/run/mpd \
- "$pkgdir"/var/log/mpd \
- "$pkgdir"/var/lib/mpd/playlists \
- "$pkgdir"/var/lib/mpd/music
-}
-md5sums="e0b7a11f86f8f021a92c49a96032ff39 mpd-0.15.6.tar.bz2
-31d1515232d688d610d1664a0fb2a6a0 mpd.initd
-dbd301041953a5cf9c2b9de8f23eb6bb mpd.confd"
diff --git a/testing/mpd/mpd.confd b/testing/mpd/mpd.confd
deleted file mode 100644
index 720306e8..00000000
--- a/testing/mpd/mpd.confd
+++ /dev/null
@@ -1,7 +0,0 @@
-# conf.d file for music player daemon
-
-#
-# Specify daemon $OPTS here.
-#
-
-OPTS=""
diff --git a/testing/mpd/mpd.initd b/testing/mpd/mpd.initd
deleted file mode 100644
index 10601dc4..00000000
--- a/testing/mpd/mpd.initd
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/sbin/runscript
-
-# init.d file for music player daemon
-
-NAME=mpd
-DAEMON=/usr/bin/$NAME
-CONF=/etc/mpd.conf
-
-depend() {
- need localmount
- use net netmount nfsmount esound pulseaudio
- after firewall
-}
-
-checkconfig() {
- [ -f "$CONF" ] && return 0
- eerror "configuration file $CONF is missing"
- return 1
-}
-
-get_pidfile() {
- pidfile=$(awk '$1 == "pid_file" { print $2 }' "$CONF")
- pidfile=${pidfile:-/var/run/mpd/$NAME.pid}
-}
-
-start() {
- checkconfig || return 1
- get_pidfile
- ebegin "Starting ${NAME}"
- start-stop-daemon --start --quiet \
- --pidfile $pidfile\
- --exec ${DAEMON} -- ${MPD_OPTS}
- eend $?
-}
-
-stop() {
- get_pidfile
- ebegin "Stopping ${NAME}"
- start-stop-daemon --stop --quiet \
- --pidfile $pidfile \
- --exec ${DAEMON}
- eend $?
-}
-
diff --git a/testing/mpd/mpd.pre-install b/testing/mpd/mpd.pre-install
deleted file mode 100644
index 4baabab1..00000000
--- a/testing/mpd/mpd.pre-install
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-adduser -h /var/lib/mpd -s /bin/false -G audio -D mpd 2>/dev/null || true
-