summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-03-23 19:38:17 +0000
committerMichael Mason <ms13sp@gmail.com>2009-03-23 19:38:17 +0000
commit505b1b1e7dffe424789fac9cd954d5afced8c9e8 (patch)
tree7e53b9f9b021b232592319db847b68a2ff39b1b5 /testing
parent132641e6a0fae14a2b8f25f98943dd2632ffde8e (diff)
downloadaports-505b1b1e7dffe424789fac9cd954d5afced8c9e8.tar.bz2
aports-505b1b1e7dffe424789fac9cd954d5afced8c9e8.tar.xz
testing/spandsp Initial commit
Diffstat (limited to 'testing')
-rw-r--r--testing/spandsp/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/spandsp/APKBUILD b/testing/spandsp/APKBUILD
new file mode 100644
index 00000000..10785366
--- /dev/null
+++ b/testing/spandsp/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor:
+# Maintainer:
+pkgname=spandsp
+pkgver=0.0.5pre4
+pkgrel=0
+pkgdesc="library to use DSP functions for telephony"
+url="http://www.soft-switch.org/"
+license="GPL"
+depends="uclibc tiff"
+makedepends="tiff-dev"
+install=
+subpackages="$pkgname-dev"
+source="http://www.soft-switch.org/downloads/spandsp/$pkgname-$pkgver.tgz"
+
+build() {
+ cd "$srcdir/$pkgname-0.0.5"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+}
+
+md5sums="fe83ed37a7831f0dd38e7ef4e7e6fd9e spandsp-0.0.5pre4.tgz"