summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-04-09 14:33:34 +0000
committerMichael Mason <ms13sp@gmail.com>2009-04-09 14:33:34 +0000
commit6434d8e541ab0d37f616516cbe851201aee9d12d (patch)
tree3dca6694254809cfc5995259726453ca379aabbf /testing
parentb3d32ec645bf269fe1011f77d53579c35d94a9e8 (diff)
downloadaports-6434d8e541ab0d37f616516cbe851201aee9d12d.tar.bz2
aports-6434d8e541ab0d37f616516cbe851201aee9d12d.tar.xz
unstable/dialog moved to testing/dialog
Diffstat (limited to 'testing')
-rw-r--r--testing/dialog/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/dialog/APKBUILD b/testing/dialog/APKBUILD
new file mode 100644
index 00000000..99878744
--- /dev/null
+++ b/testing/dialog/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer:
+pkgname=dialog
+pkgver=1.1-20080819
+pkgrel=0
+pkgdesc="A script-interpreter which provides a set of curses"
+url="http://invisible-island.net/dialog/dialog.html"
+license="GPL"
+depends="uclibc ncurses"
+makedepends="ncurses-dev"
+install=
+subpackages="$pkgname-doc"
+source="ftp://invisible-island.net/dialog/$pkgname.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="3caebd641a9f337b980becb4444336c5 dialog.tar.gz"