summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-24 16:13:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-24 16:13:34 +0000
commit6626f516085625e2b18ef7f3cb8a5a856198f4d4 (patch)
treed7f7b23a75b67fd2246ab3e49ebaba799a8ce82c /testing
parent230a508173a4ee5d9c890f2694cf8cac65ded822 (diff)
downloadaports-6626f516085625e2b18ef7f3cb8a5a856198f4d4.tar.bz2
aports-6626f516085625e2b18ef7f3cb8a5a856198f4d4.tar.xz
extra/mysql: moved from testing
seems to work
Diffstat (limited to 'testing')
-rw-r--r--testing/mysql/APKBUILD53
-rw-r--r--testing/mysql/mysql.initd38
-rw-r--r--testing/mysql/mysql.mycnf49
3 files changed, 0 insertions, 140 deletions
diff --git a/testing/mysql/APKBUILD b/testing/mysql/APKBUILD
deleted file mode 100644
index b828e9c1..00000000
--- a/testing/mysql/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-pkgname=mysql
-pkgver=5.0.75
-pkgrel=4
-pkgdesc="A fast SQL database server"
-url="http://www.mysql.com/"
-license='GPL'
-depends="readline openssl uclibc++"
-makedepends="libtool uclibc++-dev readline-dev openssl-dev"
-source="http://sunsite.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.0/${pkgname}-${pkgver}.tar.gz
-$pkgname.initd
-$pkgname.mycnf"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-test libmysqlclient"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- export CXX=g++-uc
- ./configure --prefix=/usr --libexecdir=/usr/sbin \
- --localstatedir=/var/lib/mysql \
- --disable-assembler --with-pthread \
- --without-raid --without-libwrap \
- --without-pstack --without-docs \
- --without-embedded-server --with-openssl \
- --without-mysqlfs --without-vio \
- --without-bench --without-debug \
- --with-unix-socket-path=/var/run/mysqld/mysqld.sock \
- --with-innodb --mandir=/usr/share/man || return 1
- make || return 1
- make -j1 DESTDIR="$pkgdir/" install
- install -Dm 755 "$startdir"/$pkgname.initd $pkgdir/etc/init.d/$pkgname
- install -Dm 644 "$startdir"/$pkgname.mycnf $pkgdir/etc/mysql/my.cnf
- install -dDo mysql $pkgdir/var/log/mysql
- install -dDo mysql $pkgdir/var/run/mysqld
-
- # we dont want this be pulled in in the make depends resolving but we
- # want it in the binary package dependency so we add it late.
- depends="$depends libmysqlclient"
-}
-
-libmysqlclient() {
- depends="uclibc"
- mkdir -p "$subpkgdir"/usr/lib/mysql
- mv "$pkgdir"/usr/lib/mysql/libmysqlclient.so* "$subpkgdir"/usr/lib/mysql
-}
-
-test() {
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/mysql-test "$subpkgdir"/usr/
-}
-
-md5sums="a234f0a60a7f8c290d9875cba3a2c5a2 mysql-5.0.75.tar.gz
-3ce9827b22d8fbbb29d83a91cbe98ffc mysql.initd
-15a7e3ddd6a40bf5a1eb3a8c69d9c34c mysql.mycnf"
diff --git a/testing/mysql/mysql.initd b/testing/mysql/mysql.initd
deleted file mode 100644
index 8f841646..00000000
--- a/testing/mysql/mysql.initd
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/dev-db/mysql/files/mysql.init,v 1.7 2004/07/14 21:41:15 agriffis Exp $
-
-depend() {
- need net
- use dns
-}
-
-checkconfig() {
- if [ ! -f /etc/mysql/my.cnf ] ; then
- eerror "No /etc/mysql/my.cnf file exists!"
- fi
-
- dir=`my_print_defaults -c /etc/mysql/my.cnf mysqld | grep -- --datadir | sed -e "s|^.*=\(.*\)|\1|"`
-
- if [ ! -d $dir/mysql ] ; then
- eerror "You dont appear to have the mysql database installed yet."
- eerror "Please run /usr/bin/mysql_install_db --user=mysql to have this done..."
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting mysqld"
- /usr/bin/mysqld_safe --defaults-file=/etc/mysql/my.cnf >/dev/null 2>&1 &
- eend $?
-}
-
-stop () {
- ebegin "Stopping mysqld"
- start-stop-daemon --stop --quiet \
- --pidfile=/var/run/mysqld/mysqld.pid --retry 20
- eend $?
-}
-
diff --git a/testing/mysql/mysql.mycnf b/testing/mysql/mysql.mycnf
deleted file mode 100644
index 6df0334e..00000000
--- a/testing/mysql/mysql.mycnf
+++ /dev/null
@@ -1,49 +0,0 @@
-# The following values assume you have at least 32M RAM!
-
-[client]
-#password = my_password
-port = 3306
-socket = /var/run/mysqld/mysqld.sock
-
-[safe_mysqld]
-err-log = /var/log/mysql/mysql.err
-
-[mysqld]
-# this disabled mysqld from listing on any interface.
-# Use localhost to connect to socket
-# If you need networking comment out the following line
-skip-networking
-
-# If innodb is needed commend next line
-# if not leave this to increase performance
-skip-innodb
-
-innodb_file_per_table
-user = mysql
-pid-file = /var/run/mysqld/mysqld.pid
-socket = /var/run/mysqld/mysqld.sock
-port = 3306
-
-# Only enable this if you really need it
-# eats resources.
-#log = /var/log/mysql/mysql.log
-
-basedir = /usr
-datadir = /var/lib/mysql
-tmpdir = /tmp
-language = /usr/share/mysql/english
-skip-locking
-set-variable = key_buffer=16M
-set-variable = max_allowed_packet=1M
-set-variable = thread_stack=128K
-
-[mysqldump]
-quick
-set-variable = max_allowed_packet=1M
-
-[mysql]
-#no-auto-rehash # faster start of mysql but no tab completition
-
-[isamchk]
-set-variable = key_buffer=16M
-