summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-10 13:44:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-10 13:44:15 +0000
commite88a1a6950ebb56009db8eaf1756dd6b54a04107 (patch)
tree2c97071653a281ad12ad603debf5e2b072a3e4dc /testing
parent46b98efa7d3fa629fb1819ce0cbebb700c862550 (diff)
downloadaports-e88a1a6950ebb56009db8eaf1756dd6b54a04107.tar.bz2
aports-e88a1a6950ebb56009db8eaf1756dd6b54a04107.tar.xz
testing/ucarp: added patch for useless C++ configure test
Diffstat (limited to 'testing')
-rw-r--r--testing/ucarp/APKBUILD3
-rw-r--r--testing/ucarp/nocxx.patch15
2 files changed, 18 insertions, 0 deletions
diff --git a/testing/ucarp/APKBUILD b/testing/ucarp/APKBUILD
index ed35064f..4deee45d 100644
--- a/testing/ucarp/APKBUILD
+++ b/testing/ucarp/APKBUILD
@@ -11,11 +11,13 @@ makedepends="libpcap-dev"
install=
subpackages=""
source="http://download.pureftpd.org/pub/ucarp/$pkgname-$pkgver.tar.gz
+ nocxx.patch
ucarp.initd
ucarp.confd"
build() {
cd "$srcdir/$pkgname-$pkgver"
+ patch configure < ../nocxx.patch || return 1
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -29,5 +31,6 @@ build() {
}
md5sums="ba585233e73f0dbce80427d04f431048 ucarp-1.5.tar.gz
+28513788ba4d556ccd538867dc6205ab nocxx.patch
e8f1e2fd144797524025343603dbe2b8 ucarp.initd
bf914f6ce4fe4fea33a45d4d5b2c1fff ucarp.confd"
diff --git a/testing/ucarp/nocxx.patch b/testing/ucarp/nocxx.patch
new file mode 100644
index 00000000..beb1ab90
--- /dev/null
+++ b/testing/ucarp/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc