summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2009-06-16 07:34:46 +0000
committerLeonardo Arena <rnalrd@gmail.com>2009-06-16 07:34:46 +0000
commit1763c7f0a8c41b35398c697e9e0c1b68a96b8925 (patch)
treef2a73f47be8e1ab077815ac83bb268b83ae68af3 /testing
parentef27327a99515f5aa4af6971d6959b81bb9e0c86 (diff)
downloadaports-1763c7f0a8c41b35398c697e9e0c1b68a96b8925.tar.bz2
aports-1763c7f0a8c41b35398c697e9e0c1b68a96b8925.tar.xz
testing/spamassassin: moved to extra
Diffstat (limited to 'testing')
-rw-r--r--testing/spamassassin/APKBUILD30
-rw-r--r--testing/spamassassin/spamd.conf46
-rw-r--r--testing/spamassassin/spamd.init39
3 files changed, 0 insertions, 115 deletions
diff --git a/testing/spamassassin/APKBUILD b/testing/spamassassin/APKBUILD
deleted file mode 100644
index 3da01a62..00000000
--- a/testing/spamassassin/APKBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Contributor: Leonardo Arena <rnalrd@gmail.com>
-# Maintainer: Leonardo Arena <rnalrd@gmail.com>
-pkgname=spamassassin
-_realname=Mail-SpamAssassin
-pkgver=3.2.5
-pkgrel=0
-pkgdesc="The Powerful #1 Open-Source Spam Filter"
-url="http://spamassassin.apache.org"
-license="Apache"
-depends="perl perl-digest-sha1 perl-html-parser perl-net-dns perl-db_file zlib"
-makedepends="perl-dev zlib-dev"
-install=
-subpackages="$pkgname-doc"
-source="http://www.apache.org/dist/spamassassin/source/$_realname-3.2.5.tar.gz"
-
-build() {
- cd "$srcdir/$_realname-$pkgver"
-
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make DESTDIR="$pkgdir" install
- install -m755 -D ../../spamd.init $pkgdir/etc/init.d/spamd
- install -m644 -D ../../spamd.conf $pkgdir/etc/conf.d/spamd.conf
- mkdir $pkgdir/usr/sbin
- mv $pkgdir/usr/bin/spamd $pkgdir/usr/sbin/spamd
- # creates file collision among perl modules
- rm $pkgdir/usr/lib/perl5/5.10.0/i686-linux/perllocal.pod
-}
-
-md5sums="7fdc1651d0371c4a7f95ac9ae6f828a6 Mail-SpamAssassin-3.2.5.tar.gz"
diff --git a/testing/spamassassin/spamd.conf b/testing/spamassassin/spamd.conf
deleted file mode 100644
index b6fca036..00000000
--- a/testing/spamassassin/spamd.conf
+++ /dev/null
@@ -1,46 +0,0 @@
-# Config file for /etc/init.d/spamd
-
-
-# ***WARNING***
-# spamd was not designed to listed to an untrusted network. spamd
-# is vulnerable to DoS attacks (and eternal doom) if used to listen
-# to an untrusted network.
-#
-
-
-# Some options:
-#
-# -c to create a per user configuration file
-# -H [dir] to switch home dirs for helper apps, dir optional
-# -i [ip] to listen on the specified IP,
-# 127.0.0.1 if omitted,
-# 0.0.0.0 (ie. all) if given without value;
-# must be used in combination with -A to actually allow
-# connections from anybody but localhost
-# -m limit to set the number of children, default 5
-# -u user the user to run spamd as
-# -L if you want to run no net tests
-#
-# for more help look in man spamd
-#
-# Note: if you plan on using the -u flag to spamd you will need to
-# make sure the location of the PID file is writable by that user.
-# This can be done by making the directory /var/run/spamd and
-# changing the owner to the UID that runs spamd. You will then
-# need to edit $pidfile in /etc/init.d/spamd. This should fix the
-# problem with stop/restart in the init scripts.
-#
-# See http://bugs.gentoo.org/show_bug.cgi?id=70124 for a full
-# explanation.
-
-SPAMD_OPTS="-m 5 -c -H"
-
-# spamd stores its pid in this file. If you use the -u option to
-# run spamd under another user, you might need to adjust it.
-
-PIDFILE="/var/run/spamd.pid"
-
-# SPAMD_NICELEVEL lets you set the 'nice'ness of the running
-# spamd process
-
-# SPAMD_NICELEVEL=5
diff --git a/testing/spamassassin/spamd.init b/testing/spamassassin/spamd.init
deleted file mode 100644
index 89723889..00000000
--- a/testing/spamassassin/spamd.init
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/mail-filter/spamassassin/files/3.0.0-spamd.init,v 1.8 2008/05/14 21:25:56 sbriesen Exp $
-
-# NB: Config is in /etc/conf.d/spamd
-
-# Provide a default location if they haven't in /etc/conf.d/spamd
-PIDFILE=${PIDFILE:-/var/run/spamd.pid}
-
-opts="reload"
-
-depend() {
- need net
- before mta
- use logger
-}
-
-start() {
- ebegin "Starting spamd"
- start-stop-daemon --start --quiet \
- --name spamd \
- --nicelevel ${SPAMD_NICELEVEL:-0} \
- --exec /usr/sbin/spamd -- -d -r ${PIDFILE} \
- ${SPAMD_OPTS}
- eend $? "Failed to start spamd"
-}
-
-stop() {
- ebegin "Stopping spamd"
- start-stop-daemon --stop --quiet --pidfile ${PIDFILE}
- eend $? "Failed to stop spamd"
-}
-
-reload() {
- ebegin "Reloading configuration"
- kill -HUP $(< ${PIDFILE})
- eend $?
-}