summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-01 12:21:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-01 12:21:14 +0000
commit36a4a568cbbff23ee4bdf09aa8a42cccb6595628 (patch)
tree39adf77d26909260a89fcb63a49eb8666a908c86 /testing
parent7a5096f29f4b15cf18963f6254ba7a585d7d28a0 (diff)
downloadaports-36a4a568cbbff23ee4bdf09aa8a42cccb6595628.tar.bz2
aports-36a4a568cbbff23ee4bdf09aa8a42cccb6595628.tar.xz
extra/luasql-postgres: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/luasql-postgres/APKBUILD27
-rw-r--r--testing/luasql-postgres/config.new59
2 files changed, 0 insertions, 86 deletions
diff --git a/testing/luasql-postgres/APKBUILD b/testing/luasql-postgres/APKBUILD
deleted file mode 100644
index 36756ca6..00000000
--- a/testing/luasql-postgres/APKBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Contributor: Mika Havela <mika.havela@gmail.com>
-# Maintainer: Mika Havela <mika.havela@gmail.com>
-pkgname=luasql-postgres
-pkgver=2.1.1
-pkgrel=0
-pkgdesc="LuaSQL is a simple interface from Lua to a DBMS"
-url="http://www.keplerproject.org/luasql/"
-license="MIT"
-depends="lua"
-makedepends="lua-dev postgresql-dev"
-install=
-subpackages=
-source="http://luaforge.net/frs/download.php/2686/luasql-$pkgver.tar.gz
- config.new
- "
-
-build() {
- cd "$srcdir/luasql-$pkgver"
- cp "$srcdir/config.new" config
-
- make || return 1
- mkdir -p "$pkgdir"/usr/lib/lua/5.1/luasql
- cp src/postgres.so "$pkgdir"/usr/lib/lua/5.1/luasql
-}
-
-md5sums="63bdd57de4b9d1be336ba112d8cb69eb luasql-2.1.1.tar.gz
-6ee28fa90394da6a7e38cf507d56ba80 config.new"
diff --git a/testing/luasql-postgres/config.new b/testing/luasql-postgres/config.new
deleted file mode 100644
index a8650c55..00000000
--- a/testing/luasql-postgres/config.new
+++ /dev/null
@@ -1,59 +0,0 @@
-# Driver (leave uncommented ONLY the line with the name of the driver)
-#T= mysql
-#T= oci8
-#T= odbc
-T= postgres
-#T= sqlite
-#T=sqlite3
-
-# Installation directories
-
-# Default prefix
-PREFIX = /usr
-
-# System's libraries directory (where binary libraries are installed)
-LUA_LIBDIR= $(PREFIX)/lib/lua/5.1
-
-# System's lua directory (where Lua libraries are installed)
-LUA_DIR= $(PREFIX)/share/lua/5.1
-
-# Lua includes directory
-LUA_INC= $(PREFIX)/include
-
-# Lua version number (first and second digits of target version)
-LUA_VERSION_NUM= 514
-
-# OS dependent
-LIB_OPTION= -shared #for Linux
-#LIB_OPTION= -bundle -undefined dynamic_lookup #for MacOS X
-
-LIBNAME= $T.so
-COMPAT_DIR= ../compat/src
-
-# Compilation parameters
-# Driver specific
-######## MySQL
-#DRIVER_LIBS= -L/usr/local/mysql/lib -lmysqlclient -lz
-#DRIVER_INCS= -I/usr/local/mysql/include
-######## Oracle OCI8
-#DRIVER_LIBS= -L/home/oracle/OraHome1/lib -lz -lclntsh
-#DRIVER_INCS= -I/home/oracle/OraHome1/rdbms/demo -I/home/oracle/OraHome1/rdbms/public
-######## PostgreSQL
-DRIVER_LIBS= -L/usr/pgsql/lib -lpq
-DRIVER_INCS= -I/usr/pgsql/include
-######## SQLite
-#DRIVER_LIBS= -lsqlite
-#DRIVER_INCS=
-######## SQLite3
-#DRIVER_LIBS= -L/opt/local/lib -lsqlite3
-#DRIVER_INCS= -I/opt/local/include
-######## ODBC
-#DRIVER_LIBS= -L/usr/local/lib -lodbc
-#DRIVER_INCS= -DUNIXODBC -I/usr/local/include
-
-WARN= -Wall -Wmissing-prototypes -Wmissing-declarations -ansi -pedantic
-INCS= -I$(LUA_INC)
-CFLAGS= -O2 $(WARN) -I$(COMPAT_DIR) $(DRIVER_INCS) $(INCS) $(DEFS)
-CC= gcc
-
-# $Id: config,v 1.8 2007/10/27 22:55:27 carregal Exp $