summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-10 08:14:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-10 08:14:29 +0000
commit67d02df99a5f5f77e23ee1b10e8c0ecb5e01528e (patch)
tree91e36c2f0deadb1ac5136d7cff8a86953dcebf20 /testing
parent598706e26976dc3937f9dcda5edac9b968784ffe (diff)
downloadaports-67d02df99a5f5f77e23ee1b10e8c0ecb5e01528e.tar.bz2
aports-67d02df99a5f5f77e23ee1b10e8c0ecb5e01528e.tar.xz
testing/luasql-mysql: new aport
MySQL driver for LuaSQL http://www.keplerproject.org/luasql/
Diffstat (limited to 'testing')
-rw-r--r--testing/luasql-mysql/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/luasql-mysql/APKBUILD b/testing/luasql-mysql/APKBUILD
new file mode 100644
index 00000000..42f5d760
--- /dev/null
+++ b/testing/luasql-mysql/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <natanael.copa@gmail.com>
+pkgname=luasql-mysql
+pkgver=2.1.1
+pkgrel=0
+pkgdesc="MySQL driver for LuaSQL"
+url="http://www.keplerproject.org/luasql/"
+license="MIT"
+depends="lua"
+makedepends="lua-dev mysql-dev"
+install=
+subpackages=
+source="http://luaforge.net/frs/download.php/2686/luasql-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/luasql-$pkgver
+
+ # The config has DRIVER_INCS but it seems like its not respected
+ # so we just fix the .c file
+ sed -i -e 's:^\#include "mysql.h":\#include <mysql/mysql.h>:' \
+ src/ls_mysql.c || return 1
+
+ make CFLAGS="$CFLAGS" T=mysql DRIVER_LIBS="-lmysqlclient" || return 1
+ install -D src/mysql.so "$pkgdir"/usr/lib/lua/5.1/luasql/mysql.so
+}
+
+md5sums="63bdd57de4b9d1be336ba112d8cb69eb luasql-2.1.1.tar.gz"