summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-08-05 11:29:57 +0000
committerMichael Mason <ms13sp@gmail.com>2009-08-05 11:29:57 +0000
commit7b913b7019ed0bcb950e7a58927759a72eabee70 (patch)
tree819eca8437fc5f91fefa4f036cdde53e842659f5 /testing
parent32db0ab7e85e4b927abf289faddbc07cf8b9591c (diff)
parent8154f165f6a1e4cca5c699ed2b28a746e6c039f3 (diff)
downloadaports-7b913b7019ed0bcb950e7a58927759a72eabee70.tar.bz2
aports-7b913b7019ed0bcb950e7a58927759a72eabee70.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
Diffstat (limited to 'testing')
-rw-r--r--testing/gcc/APKBUILD9
-rw-r--r--testing/gcc/uclibc-getipinfo.patch19
2 files changed, 25 insertions, 3 deletions
diff --git a/testing/gcc/APKBUILD b/testing/gcc/APKBUILD
index 8f78827e..0dd1f35b 100644
--- a/testing/gcc/APKBUILD
+++ b/testing/gcc/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gcc
pkgver=4.4.1
_specsver=0.1.4
_espfver=0.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
license="GPL LGPL"
@@ -16,6 +16,7 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
http://weaver.gentooenterprise.com/hardened/patches/gcc-$pkgver-specs-$_specsver.tar.bz2
gcc4-stack-protector-uclibc-no_tls.patch
pt_gnu_eh_frame.patch
+ uclibc-getipinfo.patch
"
# ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-objc-$pkgver.tar.bz2
build ()
@@ -60,7 +61,8 @@ build ()
--enable-shared \
--enable-target-optspace \
--with-arch=i486 \
- --with-system-zlib
+ --with-system-zlib \
+ --without-system-libunwind
make || return 1
make -j1 DESTDIR="${pkgdir}" install || return 1
@@ -119,4 +121,5 @@ d449047b5761348ceec23739f5553e0b gcc-g++-4.4.1.tar.bz2
43d0bbd676bbb2acd67ddabd0ea1bc2b gcc-4.4.1-espf-0.3.1.tar.bz2
da8d9165e828bbb9809ef86f1c72886f gcc-4.4.1-specs-0.1.4.tar.bz2
15e77082db0e1a131af98debd3016290 gcc4-stack-protector-uclibc-no_tls.patch
-2db1e3482c5dd59dab70f701afa2ca80 pt_gnu_eh_frame.patch"
+2db1e3482c5dd59dab70f701afa2ca80 pt_gnu_eh_frame.patch
+6cc2385c5bbd6d0da6eaedd53c8bf547 uclibc-getipinfo.patch"
diff --git a/testing/gcc/uclibc-getipinfo.patch b/testing/gcc/uclibc-getipinfo.patch
new file mode 100644
index 00000000..3abbbdd7
--- /dev/null
+++ b/testing/gcc/uclibc-getipinfo.patch
@@ -0,0 +1,19 @@
+--- a/libstdc++-v3/configure 2009-08-04 15:41:02.000000000 +0000
++++ b/libstdc++-v3/configure 2009-08-04 15:46:20.000000000 +0000
+@@ -113523,14 +113523,14 @@
+ # Based on system-libunwind and target, do we have ipinfo?
+ if test x$with_system_libunwind = xyes; then
+ case ${target} in
+- ia64-*-*) have_unwind_getipinfo=no ;;
++ ia64-*-*|*-uclibc*) have_unwind_getipinfo=no ;;
+ *) have_unwind_getipinfo=yes ;;
+ esac
+ else
+ # Darwin before version 9 does not have _Unwind_GetIPInfo.
+
+ case ${target} in
+- *-*-darwin[3-8]|*-*-darwin[3-8].*) have_unwind_getipinfo=no ;;
++ *-*-darwin[3-8]|*-*-darwin[3-8].*|*-uclibc*) have_unwind_getipinfo=no ;;
+ *) have_unwind_getipinfo=yes ;;
+ esac
+