summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-05 14:35:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-05 14:35:01 +0000
commitaf3ef82a15ac611eeea4beec92050f80839f4e5e (patch)
tree362ea1e37d29373c5ae07abab3d2bbc395a6682c /testing
parentb2140f790dc858f0e55c995227177d8428f0cc65 (diff)
downloadaports-af3ef82a15ac611eeea4beec92050f80839f4e5e.tar.bz2
aports-af3ef82a15ac611eeea4beec92050f80839f4e5e.tar.xz
main/gcc: moved 4.4.1 from testing to main
Diffstat (limited to 'testing')
-rw-r--r--testing/gcc/APKBUILD125
-rw-r--r--testing/gcc/gcc4-stack-protector-uclibc-no_tls.patch84
-rw-r--r--testing/gcc/pt_gnu_eh_frame.patch12
-rw-r--r--testing/gcc/uclibc-getipinfo.patch19
4 files changed, 0 insertions, 240 deletions
diff --git a/testing/gcc/APKBUILD b/testing/gcc/APKBUILD
deleted file mode 100644
index 0dd1f35b..00000000
--- a/testing/gcc/APKBUILD
+++ /dev/null
@@ -1,125 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=gcc
-pkgver=4.4.1
-_specsver=0.1.4
-_espfver=0.3.1
-pkgrel=1
-pkgdesc="The GNU Compiler Collection"
-url="http://gcc.gnu.org"
-license="GPL LGPL"
-depends="binutils"
-makedepends="bison flex gmp-dev mpfr-dev texinfo"
-subpackages="$pkgname-doc libstdc++:libcxx g++:gpp libgcc libgomp"
-source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
- ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-g++-$pkgver.tar.bz2
- http://weaver.gentooenterprise.com/hardened/patches/gcc-$pkgver-espf-$_espfver.tar.bz2
- http://weaver.gentooenterprise.com/hardened/patches/gcc-$pkgver-specs-$_specsver.tar.bz2
- gcc4-stack-protector-uclibc-no_tls.patch
- pt_gnu_eh_frame.patch
- uclibc-getipinfo.patch
- "
-# ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-objc-$pkgver.tar.bz2
-build ()
-{
- cd ${srcdir}/gcc-${pkgver}
-
- # uclibc patches
- for i in ../*.patch; do
- msg "Applying $i"
- patch -p1 -i $i || return 1
- done
-
- # ESPF patches. we dont use objc yet
- rm -f ../espf-gcc-$pkgver/*_objc*lang-specs*.patch
- # thanks to Zorry for hard work on those patches
- for i in ../espf-gcc-$pkgver/*.patch; do
- msg "Applying $i"
- patch -p0 -i $i || return 1
- done
-
- echo ${pkgver} > gcc/BASE-VER
- mkdir build
- cd build
- ../configure --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --build=${CHOST:-i486-alpine-linux-uclibc} \
- --disable-altivec \
- --disable-checking \
- --disable-fixed-point \
- --disable-libssp \
- --disable-libstdcxx-pch \
- --disable-multilib \
- --disable-nls \
- --disable-threads \
- --disable-tls \
- --disable-werror \
- --enable-__cxa_atexit \
- --enable-cld \
- --enable-espf \
- --enable-languages=c,c++ \
- --enable-shared \
- --enable-target-optspace \
- --with-arch=i486 \
- --with-system-zlib \
- --without-system-libunwind
-
- make || return 1
- make -j1 DESTDIR="${pkgdir}" install || return 1
- ln -s gcc "$pkgdir"/usr/bin/cc
-
- # binutils provides libiberty.a
- rm -f "$pkgdir"/usr/lib/libiberty.a
-
- # install the specs
- cd "$srcdir"/specs
- install -d "$pkgdir"/usr/share/gcc
- for i in *.specs; do
- install -m644 $i "$pkgdir"/usr/share/gcc/$i || return 1
- done
-}
-
-libcxx() {
- pkgdesc="GNU C++ standard runtime library"
- depends=
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libstdc++.so* "$subpkgdir"/usr/lib/
-}
-
-gpp() {
- pkgdesc="GNU C++ standard library and compiler"
- depends=
- local libexec=usr/libexec/gcc/${CHOST:-i486-alpine-linux-uclibc}/$pkgver
- mkdir -p "$subpkgdir/$libexec" \
- "$subpkgdir"/usr/bin \
- "$subpkgdir"/usr/include \
- "$subpkgdir"/usr/lib \
-
- mv "$pkgdir/$libexec/cc1plus" "$subpkgdir/$libexec/"
- mv "$pkgdir"/usr/lib/*++* "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/include/c++ "$subpkgdir"/usr/include/
- mv "$pkgdir"/usr/bin/*++ "$subpkgdir"/usr/bin/
-}
-
-libgcc() {
- pkgdesc="GNU C compiler runtime libraries"
- depends=
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libgcc_s.so* "$subpkgdir"/usr/lib/
-}
-
-libgomp() {
- pkgdesc="GCC shared-memory parallel programming API library"
- depends=
- replaces="gcc"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libgomp.so* "$subpkgdir"/usr/lib/
-}
-
-md5sums="d19693308aa6b2052e14c071111df59f gcc-core-4.4.1.tar.bz2
-d449047b5761348ceec23739f5553e0b gcc-g++-4.4.1.tar.bz2
-43d0bbd676bbb2acd67ddabd0ea1bc2b gcc-4.4.1-espf-0.3.1.tar.bz2
-da8d9165e828bbb9809ef86f1c72886f gcc-4.4.1-specs-0.1.4.tar.bz2
-15e77082db0e1a131af98debd3016290 gcc4-stack-protector-uclibc-no_tls.patch
-2db1e3482c5dd59dab70f701afa2ca80 pt_gnu_eh_frame.patch
-6cc2385c5bbd6d0da6eaedd53c8bf547 uclibc-getipinfo.patch"
diff --git a/testing/gcc/gcc4-stack-protector-uclibc-no_tls.patch b/testing/gcc/gcc4-stack-protector-uclibc-no_tls.patch
deleted file mode 100644
index c9b54adb..00000000
--- a/testing/gcc/gcc4-stack-protector-uclibc-no_tls.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-diff -u gcc/config/i386/linux.h gcc/config/i386/linux.h
---- a/gcc/config/i386/linux.h 2 Jul 2005 08:52:20 -0000 1.60
-+++ b/gcc/config/i386/linux.h 2 Jul 2005 08:52:20 -0000 1.60
-@@ -186,7 +186,7 @@
- /* This macro may be overridden in i386/k*bsd-gnu.h. */
- #define REG_NAME(reg) reg
-
--#ifdef TARGET_LIBC_PROVIDES_SSP
-+#if defined TARGET_LIBC_PROVIDES_SSP && !defined __UCLIBC__
- /* i386 glibc provides __stack_chk_guard in %gs:0x14. */
- #define TARGET_THREAD_SSP_OFFSET 0x14
- #endif
-diff -u gcc/config/i386/linux64.h gcc/config/i386/linux64.h
---- a/gcc/config/i386/linux64.h 2 Jul 2005 08:52:20 -0000 1.33
-+++ b/gcc/config/i386/linux64.h 2 Jul 2005 08:52:20 -0000 1.33
-@@ -74,7 +74,7 @@
- /* This macro may be overridden in i386/k*bsd-gnu.h. */
- #define REG_NAME(reg) reg
-
--#ifdef TARGET_LIBC_PROVIDES_SSP
-+#if defined TARGET_LIBC_PROVIDES_SSP && !defined __UCLIBC__
- /* i386 glibc provides __stack_chk_guard in %gs:0x14,
- x86_64 glibc provides it in %fs:0x28. */
- #define TARGET_THREAD_SSP_OFFSET (TARGET_64BIT ? 0x28 : 0x14)
-diff -u gcc/config/rs6000/linux.h gcc/config/rs6000/linux.h
---- a/gcc/config/rs6000/linux.h 2 Jul 2005 08:52:11 -0000 1.53
-+++ b/gcc/config/rs6000/linux.h 2 Jul 2005 08:52:11 -0000 1.53
-@@ -114,7 +114,7 @@
-
- #define MD_UNWIND_SUPPORT "config/rs6000/linux-unwind.h"
-
--#ifdef TARGET_LIBC_PROVIDES_SSP
-+#if defined TARGET_LIBC_PROVIDES_SSP && !defined __UCLIBC__
- /* ppc32 glibc provides __stack_chk_guard in -0x7008(2). */
- #define TARGET_THREAD_SSP_OFFSET -0x7008
- #endif
-diff -u gcc/config/rs6000/linux64.h gcc/config/rs6000/linux64.h
---- a/gcc/config/rs6000/linux64.h 2 Jul 2005 08:52:15 -0000 1.81
-+++ b/gcc/config/rs6000/linux64.h 2 Jul 2005 08:52:15 -0000 1.81
-@@ -548,7 +548,7 @@
-
- #define MD_UNWIND_SUPPORT "config/rs6000/linux-unwind.h"
-
--#ifdef TARGET_LIBC_PROVIDES_SSP
-+#if defined TARGET_LIBC_PROVIDES_SSP && !defined __UCLIBC__
- /* ppc32 glibc provides __stack_chk_guard in -0x7008(2),
- ppc64 glibc provides it at -0x7010(13). */
- #define TARGET_THREAD_SSP_OFFSET (TARGET_64BIT ? -0x7010 : -0x7008)
-diff -u gcc/config/s390/linux.h gcc/config/s390/linux.h
---- a/gcc/config/s390/linux.h 2005-08-22 15:53:01.000000000 +0200 1.40
-+++ b/gcc/config/s390/linux.h 2005-08-22 15:53:01.000000000 +0200 1.40
-@@ -94,7 +94,7 @@
-
- #define MD_UNWIND_SUPPORT "config/s390/linux-unwind.h"
-
--#ifdef TARGET_LIBC_PROVIDES_SSP
-+#if defined TARGET_LIBC_PROVIDES_SSP && !defined __UCLIBC__
- /* s390 glibc provides __stack_chk_guard in 0x14(tp),
- s390x glibc provides it at 0x28(tp). */
- #define TARGET_THREAD_SSP_OFFSET (TARGET_64BIT ? 0x28 : 0x14)
-diff -u gcc/config/sparc/linux.h gcc/config/sparc/linux.h
---- a/gcc/config/sparc/linux.h 6 Jul 2005 07:48:57 -0000 1.72
-+++ b/gcc/config/sparc/linux.h 6 Jul 2005 07:48:57 -0000 1.72
-@@ -230,7 +230,7 @@
- #undef NEED_INDICATE_EXEC_STACK
- #define NEED_INDICATE_EXEC_STACK 1
-
--#ifdef TARGET_LIBC_PROVIDES_SSP
-+#if defined TARGET_LIBC_PROVIDES_SSP && !defined __UCLIBC__
- /* sparc glibc provides __stack_chk_guard in [%g7 + 0x14]. */
- #define TARGET_THREAD_SSP_OFFSET 0x14
- #endif
-diff -u gcc/config/sparc/linux64.h gcc/config/sparc/linux64.h
---- a/gcc/config/sparc/linux64.h 6 Jul 2005 07:48:57 -0000 1.95
-+++ b/gcc/config/sparc/linux64.h 6 Jul 2005 07:48:57 -0000 1.95
-@@ -364,7 +364,7 @@
- #undef NEED_INDICATE_EXEC_STACK
- #define NEED_INDICATE_EXEC_STACK 1
-
--#ifdef TARGET_LIBC_PROVIDES_SSP
-+#if defined TARGET_LIBC_PROVIDES_SSP && !defined __UCLIBC__
- /* sparc glibc provides __stack_chk_guard in [%g7 + 0x14],
- sparc64 glibc provides it at [%g7 + 0x28]. */
- #define TARGET_THREAD_SSP_OFFSET (TARGET_ARCH64 ? 0x28 : 0x14)
diff --git a/testing/gcc/pt_gnu_eh_frame.patch b/testing/gcc/pt_gnu_eh_frame.patch
deleted file mode 100644
index 3e029104..00000000
--- a/testing/gcc/pt_gnu_eh_frame.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- gcc-4.3.2/gcc/crtstuff.c.orig Mon Nov 17 16:02:38 2008
-+++ gcc-4.3.2/gcc/crtstuff.c Mon Nov 17 16:02:52 2008
-@@ -94,8 +94,7 @@
- #include <link.h>
- /* uClibc pretends to be glibc 2.2 and DT_CONFIG is defined in its link.h.
- But it doesn't use PT_GNU_EH_FRAME ELF segment currently. */
--# if !defined(__UCLIBC__) \
-- && (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ > 2) \
-+# if (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ > 2) \
- || (__GLIBC__ == 2 && __GLIBC_MINOR__ == 2 && defined(DT_CONFIG)))
- # define USE_PT_GNU_EH_FRAME
- # endif
diff --git a/testing/gcc/uclibc-getipinfo.patch b/testing/gcc/uclibc-getipinfo.patch
deleted file mode 100644
index 3abbbdd7..00000000
--- a/testing/gcc/uclibc-getipinfo.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/libstdc++-v3/configure 2009-08-04 15:41:02.000000000 +0000
-+++ b/libstdc++-v3/configure 2009-08-04 15:46:20.000000000 +0000
-@@ -113523,14 +113523,14 @@
- # Based on system-libunwind and target, do we have ipinfo?
- if test x$with_system_libunwind = xyes; then
- case ${target} in
-- ia64-*-*) have_unwind_getipinfo=no ;;
-+ ia64-*-*|*-uclibc*) have_unwind_getipinfo=no ;;
- *) have_unwind_getipinfo=yes ;;
- esac
- else
- # Darwin before version 9 does not have _Unwind_GetIPInfo.
-
- case ${target} in
-- *-*-darwin[3-8]|*-*-darwin[3-8].*) have_unwind_getipinfo=no ;;
-+ *-*-darwin[3-8]|*-*-darwin[3-8].*|*-uclibc*) have_unwind_getipinfo=no ;;
- *) have_unwind_getipinfo=yes ;;
- esac
-