summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-14 18:41:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-14 18:42:50 +0000
commitc719c051a384291a1e4965ebff3af3a969a22e78 (patch)
treee90e3f7dfb343f2718269ae173c7706599277fb0 /testing
parent918cae047812a43fe65e86a2910ae65a2d28b7c0 (diff)
downloadaports-c719c051a384291a1e4965ebff3af3a969a22e78.tar.bz2
aports-c719c051a384291a1e4965ebff3af3a969a22e78.tar.xz
testing/compat-wireless-grsec: new aport
grsec kernel backported wifi drivers http://linuxwireless.org/en/users/Download/stable/
Diffstat (limited to 'testing')
-rw-r--r--testing/compat-wireless-grsec/APKBUILD36
-rw-r--r--testing/compat-wireless-grsec/makefile.patch74
2 files changed, 110 insertions, 0 deletions
diff --git a/testing/compat-wireless-grsec/APKBUILD b/testing/compat-wireless-grsec/APKBUILD
new file mode 100644
index 00000000..63b5cfb4
--- /dev/null
+++ b/testing/compat-wireless-grsec/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+_flavor=grsec
+_realname=compat-wireless
+# source the kernel version
+if [ -f ../../main/linux-$_flavor/APKBUILD ]; then
+ . ../../main/linux-$_flavor/APKBUILD
+fi
+_kernelver=$pkgver-r$pkgrel
+
+pkgname=${_realname}-${_flavor}
+pkgver=2.6.30
+pkgrel=0
+pkgdesc="$_flavor kernel backported wifi drivers"
+url="http://linuxwireless.org/en/users/Download/stable/"
+license="GPL-2"
+depends="linux-${_flavor}=${_kernelver}"
+install=
+makedepends="linux-${_flavor}-dev=${_kernelver}"
+subpackages=
+source="http://www.orbit-lab.org/kernel/compat-wireless-2.6-stable/v$pkgver/compat-wireless-$pkgver.tar.bz2
+ makefile.patch
+ "
+
+build() {
+ local _abi_release=$(cat /usr/share/linux-$_flavor/kernel.release)
+ cd "$srcdir"/$_realname-$pkgver
+ patch -p1 -i ../makefile.patch || return 1
+ unset ARCH
+ make KLIB="/lib/modules/${_abi_release}" DEPMOD=: MODPROBE=: \
+ || return 1
+ make KLIB="/lib/modules/${_abi_release}" DEPMOD=: MODPROBE=: \
+ DESTDIR="$pkgdir" install-kernel || return 1
+}
+md5sums="d1e4d0f2b30ffe2931c6fad8d6607e17 compat-wireless-2.6.30.tar.bz2
+9ad34341eeaccb739c6f8e638af67088 makefile.patch"
diff --git a/testing/compat-wireless-grsec/makefile.patch b/testing/compat-wireless-grsec/makefile.patch
new file mode 100644
index 00000000..0f1ef022
--- /dev/null
+++ b/testing/compat-wireless-grsec/makefile.patch
@@ -0,0 +1,74 @@
+diff -ru a/Makefile b/Makefile
+--- a/Makefile 2009-09-02 21:32:42.000000000 +0000
++++ b/Makefile 2009-09-02 21:37:18.000000000 +0000
+@@ -8,6 +8,7 @@
+ export KLIB_BUILD ?= $(KLIB)/build
+ # Sometimes not available in the path
+ MODPROBE := /sbin/modprobe
++DEPMOD := /sbin/depmod
+ MADWIFI=$(shell $(MODPROBE) -l ath_pci)
+ OLD_IWL=$(shell $(MODPROBE) -l iwl4965)
+
+@@ -58,20 +59,24 @@
+ @touch $@
+ @md5sum $(COMPAT_CONFIG) > $(CONFIG_CHECK)
+
+-install: uninstall modules
++install: install-kernel install-user
++
++install-kernel: uninstall modules
+ $(MAKE) -C $(KLIB_BUILD) M=$(PWD) $(KMODDIR_ARG) $(KMODPATH_ARG) \
+- modules_install
++ INSTALL_MOD_PATH=$(DESTDIR) modules_install
++
++install-user:
+ @# All the scripts we can use
+- @mkdir -p /usr/lib/compat-wireless/
+- @install scripts/modlib.sh /usr/lib/compat-wireless/
+- @install scripts/madwifi-unload /usr/sbin/
++ @mkdir -p $(DESTDIR)/usr/lib/compat-wireless/ $(DESTDIR)/usr/sbin/
++ @install scripts/modlib.sh $(DESTDIR)/usr/lib/compat-wireless/
++ @install scripts/madwifi-unload $(DESTDIR)/usr/sbin/
+ @# This is to allow switching between drivers without blacklisting
+- @install scripts/athenable /usr/sbin/
+- @install scripts/b43enable /usr/sbin/
+- @install scripts/iwl-enable /usr/sbin/
+- @install scripts/athload /usr/sbin/
+- @install scripts/b43load /usr/sbin/
+- @install scripts/iwl-load /usr/sbin/
++ @install scripts/athenable $(DESTDIR)/usr/sbin/
++ @install scripts/b43enable $(DESTDIR)/usr/sbin/
++ @install scripts/iwl-enable $(DESTDIR)/usr/sbin/
++ @install scripts/athload $(DESTDIR)/usr/sbin/
++ @install scripts/b43load $(DESTDIR)/usr/sbin/
++ @install scripts/iwl-load $(DESTDIR)/usr/sbin/
+ @if [ ! -z $(MADWIFI) ]; then \
+ echo ;\
+ echo -n "Note: madwifi detected, we're going to disable it. " ;\
+@@ -96,7 +101,7 @@
+ @# won't know mac80211.ko should be used instead of
+ @# mac80211.ko.gz
+ @./scripts/compress_modules
+- @/sbin/depmod -ae
++ @$(DEPMOD) -ae
+ @echo
+ @echo "Currently detected wireless subsystem modules:"
+ @echo
+@@ -158,7 +163,7 @@
+ @rm -f $(KLIB)/$(KMODDIR)/drivers/misc/eeprom/eeprom_93cx6.ko*
+ @rm -f $(KLIB)/$(KMODDIR)/drivers/misc/eeprom_93cx6.ko*
+ @rm -f $(KLIB)/$(KMODDIR)/drivers/net/b44.ko*
+- @/sbin/depmod -ae
++ @$(DEPMOD) -ae
+ @echo
+ @echo "Your old wireless subsystem modules were left intact:"
+ @echo
+@@ -214,7 +219,7 @@
+ load: unload
+ @./scripts/load.sh
+
+-.PHONY: all clean install uninstall unload load
++.PHONY: all clean install install-kernel install-user uninstall unload load
+
+ endif
+