summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-25 08:21:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-25 08:22:55 +0000
commita3760f21760b90df11cd6b93ce283dd2407253fb (patch)
tree85df7405cb79d2f3956178be089131d37803e9fc /testing
parent2201bb19f8db8978d3573f64eb67d5e0ef33bb4a (diff)
downloadaports-a3760f21760b90df11cd6b93ce283dd2407253fb.tar.bz2
aports-a3760f21760b90df11cd6b93ce283dd2407253fb.tar.xz
testing/ivtv-utils: new aport
Userspace utilities and firmware for Hauppauge PVR cards http://ivtvdriver.org
Diffstat (limited to 'testing')
-rw-r--r--testing/ivtv-utils/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/ivtv-utils/APKBUILD b/testing/ivtv-utils/APKBUILD
new file mode 100644
index 00000000..33bccec5
--- /dev/null
+++ b/testing/ivtv-utils/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ivtv-utils
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Userspace utilities and firmware for Hauppauge PVR cards"
+url="http://ivtvdriver.org"
+license="GPL"
+depends=
+makedepends="uclibc++-dev"
+source="http://dl.ivtvdriver.org/ivtv/stable/$pkgname-$pkgver.tar.gz
+ http://dl.ivtvdriver.org/ivtv/firmware/ivtv-firmware.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ export CXX=${CXX_UC:-g++-uc}
+ make || return 1
+ make DESTDIR="$pkgdir" PREFIX=/usr install || return 1
+
+ cd "$srcdir"
+ for file in *.fw v4l-cx2341x-init.mpg; do
+ install -D -m644 $file "$pkgdir"/lib/firmware/$file || return 1
+ done
+ rm -rf "$pkgdir"/usr/include
+}
+
+md5sums="13deb3fe973b175a115285e63f668b95 ivtv-utils-1.4.0.tar.gz
+b9a871f1c569025be9c48a77b3515faf ivtv-firmware.tar.gz"