summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-09-17 15:54:03 +0000
committerMichael Mason <ms13sp@gmail.com>2009-09-17 15:54:03 +0000
commitaf748fa3c0c5ded4b150da42c292ebb5c399f704 (patch)
tree137e9726ba80838ce68bbddb7fa43f13c2e168f4 /testing
parent432027a138a77423d49085c341bf2a9d2939f01b (diff)
downloadaports-af748fa3c0c5ded4b150da42c292ebb5c399f704.tar.bz2
aports-af748fa3c0c5ded4b150da42c292ebb5c399f704.tar.xz
testing/pllua Initial Commit
Diffstat (limited to 'testing')
-rw-r--r--testing/pllua/APKBUILD36
-rw-r--r--testing/pllua/pllua-01-0.3.1-include.patch14
2 files changed, 50 insertions, 0 deletions
diff --git a/testing/pllua/APKBUILD b/testing/pllua/APKBUILD
new file mode 100644
index 00000000..09ef17f5
--- /dev/null
+++ b/testing/pllua/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=pllua
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="Procedural language for PostgreSQL using Lua"
+url="http://pgfoundry.org/projects/pllua"
+license="GPL"
+depends="postgresql"
+makedepends="postgresql-dev lua-dev ccache"
+install=
+subpackages=""
+source="http://pgfoundry.org/frs/download.php/1722/$pkgname-$pkgver.tar.gz
+ pllua-01-0.3.1-include.patch"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in "$srcdir"/*.patch; do
+ msg "Applying ${i}"
+ patch -p1 -i $i || return 1
+ done
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="e57385bdf2d533ac73cd02401795cea8 pllua-0.3.1.tar.gz
+a47387e64b7dba8d58237c7dad0e2d61 pllua-01-0.3.1-include.patch"
diff --git a/testing/pllua/pllua-01-0.3.1-include.patch b/testing/pllua/pllua-01-0.3.1-include.patch
new file mode 100644
index 00000000..afbf8a98
--- /dev/null
+++ b/testing/pllua/pllua-01-0.3.1-include.patch
@@ -0,0 +1,14 @@
+#most of fix from here http://postgis.refractions.net/pipermail/postgis-devel/2009-February/004879.html
+--- pllua-0.3.1/plluaapi.c.orig Thu Sep 17 15:34:07 2009
++++ pllua-0.3.1/plluaapi.c Thu Sep 17 15:34:18 2009
+@@ -7,6 +7,10 @@
+
+ #include "pllua.h"
+ #include "rowstamp.h"
++#include "utils/guc.h"
++extern Datum textout (PG_FUNCTION_ARGS);
++extern Datum bpcharout(PG_FUNCTION_ARGS);
++extern Datum varcharout(PG_FUNCTION_ARGS);
+
+ /* extended function info */
+ typedef struct luaP_Info {