summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-19 20:04:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-19 20:04:21 +0000
commitb99fd992136d4691884b8f103e04c2df7403ade4 (patch)
treea284205200eb8c19902b90120fcb98c64ad390a4 /testing
parenta7195df5af0c004dabe03b63339886ed3b60b27c (diff)
parentaf748fa3c0c5ded4b150da42c292ebb5c399f704 (diff)
downloadaports-b99fd992136d4691884b8f103e04c2df7403ade4.tar.bz2
aports-b99fd992136d4691884b8f103e04c2df7403ade4.tar.xz
Merge remote branch 'remotes/mmason/master'
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-io-multiplex/APKBUILD26
-rw-r--r--testing/perl-net-rblcient/APKBUILD26
-rw-r--r--testing/perl-parse-syslog/APKBUILD26
-rw-r--r--testing/pllua/APKBUILD36
-rw-r--r--testing/pllua/pllua-01-0.3.1-include.patch14
5 files changed, 128 insertions, 0 deletions
diff --git a/testing/perl-io-multiplex/APKBUILD b/testing/perl-io-multiplex/APKBUILD
new file mode 100644
index 00000000..e5d9bc06
--- /dev/null
+++ b/testing/perl-io-multiplex/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=perl-io-multiplex
+_realname=IO-Multiplex
+pkgver=1.10
+pkgrel=0
+pkgdesc="Manage IO on many file handles"
+url="http://search.cpan.org/dist/IO-Multiplex/"
+license="unknown"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BB/BBB/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="ce230ee0a4afbff59da66f0c42e0340b IO-Multiplex-1.10.tar.gz"
diff --git a/testing/perl-net-rblcient/APKBUILD b/testing/perl-net-rblcient/APKBUILD
new file mode 100644
index 00000000..e68eaae2
--- /dev/null
+++ b/testing/perl-net-rblcient/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=perl-net-rblclient
+_realname=Net-RBLClient
+pkgver=0.5
+pkgrel=0
+pkgdesc="Queries multiple Realtime Blackhole Lists in parallel"
+url="http://search.cpan.org/dist/Net-RBLClient/"
+license="unknown"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AB/ABLUM/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/RBLCLient-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="1fb9961106cbb5a6eb2257762847e502 Net-RBLClient-0.5.tar.gz"
diff --git a/testing/perl-parse-syslog/APKBUILD b/testing/perl-parse-syslog/APKBUILD
new file mode 100644
index 00000000..af6da0fe
--- /dev/null
+++ b/testing/perl-parse-syslog/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=perl-parse-syslog
+_realname=Parse-Syslog
+pkgver=1.10
+pkgrel=0
+pkgdesc="Parse Unix syslog files"
+url="http://search.cpan.org/~dschwei/Parse-Syslog-1.10/"
+license="unknown"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/D/DS/DSCHWEI/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="e1c4c03aaa7cb8d2baa52f294dd9accc Parse-Syslog-1.10.tar.gz"
diff --git a/testing/pllua/APKBUILD b/testing/pllua/APKBUILD
new file mode 100644
index 00000000..09ef17f5
--- /dev/null
+++ b/testing/pllua/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=pllua
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="Procedural language for PostgreSQL using Lua"
+url="http://pgfoundry.org/projects/pllua"
+license="GPL"
+depends="postgresql"
+makedepends="postgresql-dev lua-dev ccache"
+install=
+subpackages=""
+source="http://pgfoundry.org/frs/download.php/1722/$pkgname-$pkgver.tar.gz
+ pllua-01-0.3.1-include.patch"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in "$srcdir"/*.patch; do
+ msg "Applying ${i}"
+ patch -p1 -i $i || return 1
+ done
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="e57385bdf2d533ac73cd02401795cea8 pllua-0.3.1.tar.gz
+a47387e64b7dba8d58237c7dad0e2d61 pllua-01-0.3.1-include.patch"
diff --git a/testing/pllua/pllua-01-0.3.1-include.patch b/testing/pllua/pllua-01-0.3.1-include.patch
new file mode 100644
index 00000000..afbf8a98
--- /dev/null
+++ b/testing/pllua/pllua-01-0.3.1-include.patch
@@ -0,0 +1,14 @@
+#most of fix from here http://postgis.refractions.net/pipermail/postgis-devel/2009-February/004879.html
+--- pllua-0.3.1/plluaapi.c.orig Thu Sep 17 15:34:07 2009
++++ pllua-0.3.1/plluaapi.c Thu Sep 17 15:34:18 2009
+@@ -7,6 +7,10 @@
+
+ #include "pllua.h"
+ #include "rowstamp.h"
++#include "utils/guc.h"
++extern Datum textout (PG_FUNCTION_ARGS);
++extern Datum bpcharout(PG_FUNCTION_ARGS);
++extern Datum varcharout(PG_FUNCTION_ARGS);
+
+ /* extended function info */
+ typedef struct luaP_Info {