summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-09-03 13:07:39 +0000
committerMichael Mason <ms13sp@gmail.com>2009-09-03 13:07:39 +0000
commitd4256a9e2e2ed711d0901f7f827af7996da362bc (patch)
treed852d88aa845019bca7133d9ce0445bc04227732 /testing
parent840b06f3395af637d1f777ee760c6cf5c6a7179e (diff)
downloadaports-d4256a9e2e2ed711d0901f7f827af7996da362bc.tar.bz2
aports-d4256a9e2e2ed711d0901f7f827af7996da362bc.tar.xz
testing/perl-io-multiplex initial commit
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-io-multi/APKBUILD26
-rw-r--r--testing/perl-io-multiplex/APKBUILD26
2 files changed, 52 insertions, 0 deletions
diff --git a/testing/perl-io-multi/APKBUILD b/testing/perl-io-multi/APKBUILD
new file mode 100644
index 00000000..9e03f039
--- /dev/null
+++ b/testing/perl-io-multi/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=perl-io-multiplex
+_realname=IO-Multiplex
+pkgver=1.10
+pkgrel=0
+pkgdesc="Manage IO on many file handles"
+url="http://search.cpan.org/~rhandom/Net-Server-0.97/"
+license="unknown"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BB/BBB/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="ce230ee0a4afbff59da66f0c42e0340b IO-Multiplex-1.10.tar.gz"
diff --git a/testing/perl-io-multiplex/APKBUILD b/testing/perl-io-multiplex/APKBUILD
new file mode 100644
index 00000000..9e03f039
--- /dev/null
+++ b/testing/perl-io-multiplex/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=perl-io-multiplex
+_realname=IO-Multiplex
+pkgver=1.10
+pkgrel=0
+pkgdesc="Manage IO on many file handles"
+url="http://search.cpan.org/~rhandom/Net-Server-0.97/"
+license="unknown"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BB/BBB/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="ce230ee0a4afbff59da66f0c42e0340b IO-Multiplex-1.10.tar.gz"