summaryrefslogtreecommitdiffstats
path: root/unstable
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-06-04 19:51:57 +0000
committerMichael Mason <ms13sp@gmail.com>2009-06-04 19:51:57 +0000
commitbe106f356ad5e840fdb6abacf54486d774932cf1 (patch)
tree56546b775c5d95cb45985fd7d277b11965249196 /unstable
parent25d7d59ce4e13362edac1517344dad895be10ac4 (diff)
downloadaports-be106f356ad5e840fdb6abacf54486d774932cf1.tar.bz2
aports-be106f356ad5e840fdb6abacf54486d774932cf1.tar.xz
Moved unstable/luaexpat unstable/luasocket to testing. Adding more prosody files
Diffstat (limited to 'unstable')
-rw-r--r--unstable/luaexpat/APKBUILD25
-rw-r--r--unstable/luaexpat/newconfig26
-rw-r--r--unstable/luasocket/APKBUILD22
-rw-r--r--unstable/prosody/Makefile-0.4.2.patch13
-rw-r--r--unstable/prosody/prosody.cfg.lua107
-rw-r--r--unstable/prosody/prosody.initd43
-rw-r--r--unstable/prosody/prosody.post-install6
-rw-r--r--unstable/prosody/prosody.pre-install9
8 files changed, 178 insertions, 73 deletions
diff --git a/unstable/luaexpat/APKBUILD b/unstable/luaexpat/APKBUILD
deleted file mode 100644
index e11ba107..00000000
--- a/unstable/luaexpat/APKBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# Contributor: Mika Havela <mika.havela@gmail.com>
-# Maintainer: Mika Havela <mika.havela@gmail.com>
-pkgname=luaexpat
-pkgver=1.1
-pkgrel=0
-pkgdesc="LuaExpat is a SAX XML parser based on the Expat library. LuaExpat is free software and uses the same license as Lua 5.0."
-url="http://luaforge.net/projects/luaexpat/"
-license="MIT"
-depends="lua expat uclibc"
-makedepends="lua-dev expat-dev"
-install=
-source="http://luaforge.net/frs/download.php/2469/$pkgname-$pkgver.tar.gz
-newconfig"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- mv ../newconfig ./config
-
- make || return 1
- make LUA_DIR="$pkgdir"/usr/share/lua/5.1 LUA_LIBDIR="$pkgdir"/usr/lib/lua/5.1 install
-
-}
-
-md5sums="6ecb895ccf5cff1e7f2facd438b1f8d0 luaexpat-1.1.tar.gz
-eb947b7aa99b487289b02c1ab1b8ccd3 newconfig"
diff --git a/unstable/luaexpat/newconfig b/unstable/luaexpat/newconfig
deleted file mode 100644
index 7d8d6331..00000000
--- a/unstable/luaexpat/newconfig
+++ /dev/null
@@ -1,26 +0,0 @@
-LUA_LIBDIR= usr/lib/lua/5.1
-LUA_DIR= usr/share/lua/5.1
-LUA_INC= /usr/include
-EXPAT_INC= /usr/include
-
-# OS dependent
-LIB_OPTION= -shared
-
-LIBNAME= $T.so.$V
-LUA_VERSION_NUM= 514
-COMPAT_DIR= ../compat/src
-
-# Compilation parameters
-CWARNS = -Wall -pedantic \
- -Waggregate-return \
- -Wcast-align \
- -Wmissing-prototypes \
- -Wstrict-prototypes \
- -Wnested-externs \
- -Wpointer-arith \
- -Wshadow \
- -Wwrite-strings
-
-CFLAGS = $(CWARNS) -ansi -O2 -I$(LUA_INC) \
- -I$(COMPAT_DIR) -I$(EXPAT_INC)
-CC = gcc
diff --git a/unstable/luasocket/APKBUILD b/unstable/luasocket/APKBUILD
deleted file mode 100644
index c42a6229..00000000
--- a/unstable/luasocket/APKBUILD
+++ /dev/null
@@ -1,22 +0,0 @@
-# Contributor: Mika Havela <mika.havela@gmail.com>
-# Maintainer: Mika Havela <mika.havela@gmail.com>
-pkgname=luasocket
-pkgver=2.0.2
-pkgrel=0
-pkgdesc="Luasocket is the most comprehensive networking support library for the Lua language."
-url="http://luaforge.net/projects/luasocket/"
-license="MIT"
-depends="lua"
-makedepends="lua-dev"
-install=
-source="http://luaforge.net/frs/download.php/2664/$pkgname-$pkgver.tar.gz"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- make || return 1
- make INSTALL_TOP_SHARE="$pkgdir/usr/share/lua/5.1" INSTALL_TOP_LIB="$pkgdir/usr/lib/lua/5.1" install
-
-}
-
-md5sums="41445b138deb7bcfe97bff957503da8e luasocket-2.0.2.tar.gz"
diff --git a/unstable/prosody/Makefile-0.4.2.patch b/unstable/prosody/Makefile-0.4.2.patch
new file mode 100644
index 00000000..facfa2f9
--- /dev/null
+++ b/unstable/prosody/Makefile-0.4.2.patch
@@ -0,0 +1,13 @@
+--- src/prosody-0.4.2/Makefile.org Thu Jun 4 13:44:20 2009
++++ src/prosody-0.4.2/Makefile Thu Jun 4 13:44:11 2009
+@@ -19,8 +19,8 @@
+ install -d $(BIN) $(CONFIG) $(MODULES) $(SOURCE) $(DATA)
+ install -d $(CONFIG)/certs
+ install -d $(SOURCE)/core $(SOURCE)/net $(SOURCE)/util
+- install ./prosody.install $(BIN)/prosody
+- install ./prosodyctl.install $(BIN)/prosodyctl
++ install -m755 ./prosody.install $(BIN)/prosody
++ install -m755 ./prosodyctl.install $(BIN)/prosodyctl
+ install -m644 core/* $(SOURCE)/core
+ install -m644 net/* $(SOURCE)/net
+ install -m644 util/* $(SOURCE)/util
diff --git a/unstable/prosody/prosody.cfg.lua b/unstable/prosody/prosody.cfg.lua
new file mode 100644
index 00000000..99df66ad
--- /dev/null
+++ b/unstable/prosody/prosody.cfg.lua
@@ -0,0 +1,107 @@
+-- Prosody Configuration File
+--
+-- If it wasn't already obvious, -- starts a comment, and all text after it on
+-- a line is ignored by Prosody.
+--
+-- The config is split into sections, a global section, and one for each
+-- defined host that we serve. You can add as many host sections as you like.
+--
+-- Lists are written { "like", "this", "one" }
+-- Lists can also be of { 1, 2, 3 } numbers, etc.
+-- Either commas, or semi-colons; may be used as seperators.
+--
+-- A table is a list of values, except each value has a name. An example would
+-- be:
+--
+-- logging = { type = "html", directory = "/var/logs", rotate = "daily" }
+--
+-- Whitespace (that is tabs, spaces, line breaks) is mostly insignificant, so
+-- can
+-- be placed anywhere
+-- that you deem fitting.
+--
+-- Tip: You can check that the syntax of this file is correct when you have
+-- finished by running: luac -p prosody.cfg.lua
+-- If there are any errors, it will let you know what and where they are,
+-- otherwise it will keep quiet.
+--
+-- Good luck, and happy Jabbering!
+
+-- Global settings go in this section
+Host "*"
+ -- This is the list of modules Prosody will load on startup.
+ -- It looks for mod_modulename.lua in the plugins folder, so make sure that
+ -- exists too.
+ modules_enabled = {
+ -- Generally required
+ "roster"; -- Allow users to have a roster. Recommended ;)
+ "saslauth"; -- Authentication for clients and servers. Recommended
+ -- if you want to log in.
+ "tls"; -- Add support for secure TLS on c2s/s2s connections
+ "dialback"; -- s2s dialback support
+ "disco"; -- Service discovery
+
+ -- Not essential, but recommended
+ "private"; -- Private XML storage (for room bookmarks, etc.)
+ "vcard"; -- Allow users to set vCards
+
+ -- Nice to have
+ "legacyauth"; -- Legacy authentication. Only used by some old
+ -- clients and bots.
+ "version"; -- Replies to server version requests
+ "uptime"; -- Report how long server has been running
+ "time"; -- Let others know the time here on this server
+ "ping"; -- Replies to XMPP pings with pongs
+
+ -- Required for daemonizing and logging
+ "posix"; -- POSIX functionality, sends server to background,
+ -- enables syslog, etc.
+
+ -- Other specific functionality
+ "register"; -- Allow users to register on this server using a
+ -- client
+ --"console"; -- telnet to port 5582 (needs console_enabled = true)
+ --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
+ --"httpserver"; -- Serve static files from a directory over HTTP
+ }
+
+ -- These are the SSL/TLS-related settings. If you don't want to use
+ -- SSL/TLS, you may comment or remove this
+ --ssl = {
+ -- key = "/etc/prosody/certs/localhost.key";
+ -- certificate = "/etc/prosody/certs/localhost.cert";
+ --}
+
+ log = {
+ -- Log all error messages to prosody.err
+ { levels = { min = "error" }, to = "file", timestamps = true,
+ filename = "/var/log/prosody/prosody.err" };
+ -- Log everything of level "info" and higher (that is, all except
+ -- "debug" messages) to prosody.log
+ { levels = { min = "info" }, to = "file", timestamps = true,
+ filename = "/var/log/prosody/prosody.log" };
+ }
+
+ -- Required for proper daemonization support
+ pidfile = "/var/run/prosody/prosody.pid"
+
+-- This allows clients to connect to localhost. No harm in it.
+Host "localhost"
+
+-- Section for example.com
+-- (replace example.com with your domain name)
+Host "example.com"
+ -- Assign this host a certificate for TLS, otherwise it would use the one
+ -- set in the global section (if any).
+ -- Note that old-style SSL on port 5223 only supports one certificate, and
+ -- will always use the global one.
+ --ssl = {
+ -- key = "/etc/prosody/certs/example.com.key";
+ -- certificate = "/etc/prosody/certs/example.com.crt";
+ --}
+
+ enabled = false -- This will disable the host, preserving the config, but
+ -- denying connections
+
+-- Set up a MUC (multi-user chat) room server on conference.localhost:
+Component "conference.localhost" "muc"
diff --git a/unstable/prosody/prosody.initd b/unstable/prosody/prosody.initd
new file mode 100644
index 00000000..1c88672b
--- /dev/null
+++ b/unstable/prosody/prosody.initd
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+
+# Sample init.d file for alpine linux.
+
+NAME=prosody
+DAEMON=/usr/bin/$NAME
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${NAME}"
+ /usr/bin/prosodyctl start
+# start-stop-daemon --start --quiet --background \
+# --make-pidfile --pidfile /var/run/${NAME}/${NAME}.pid \
+# --chuid ${USER}:${GROUP} \
+# --exec ${DAEMON} -- ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${NAME}"
+ /usr/bin/prosodyctl stop
+# start-stop-daemon --stop --quiet \
+# --exec ${DAEMON} \
+# --pidfile /var/run/${NAME}/${NAME}.pid \
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${NAME}"
+ if ! service_started "${NAME}" ; then
+ eend 1 "${NAME} is not started"
+ return 1
+ fi
+ /usr/bin/prosodyctl stop
+ /usr/bin/prosodyctl start
+# start-stop-daemon --stop --oknodo --signal HUP \
+# --exec ${DAEMON} --pidfile /var/run/${NAME}/${NAME}.pid
+ eend $?
+}
+
diff --git a/unstable/prosody/prosody.post-install b/unstable/prosody/prosody.post-install
new file mode 100644
index 00000000..2f8f69cd
--- /dev/null
+++ b/unstable/prosody/prosody.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+chown prosody:prosody var/lib/prosody
+chown prosody:prosody var/log/prosody
+chown prosody:prosody var/run/prosody
+
diff --git a/unstable/prosody/prosody.pre-install b/unstable/prosody/prosody.pre-install
new file mode 100644
index 00000000..db63efa1
--- /dev/null
+++ b/unstable/prosody/prosody.pre-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+user=prosody
+home=/var/lib/prosody
+adduser -h $home -s /bin/false -D $user 2>/dev/null
+mkdir -p $home
+chown $user:$user $home
+exit 0
+