summaryrefslogtreecommitdiffstats
path: root/x11/atk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-27 19:27:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-27 19:27:57 +0000
commit42ef369b4137842470261877a934b5a10eb53285 (patch)
tree682b28a534d506bbadecb9ac431c92058f6ac432 /x11/atk
parentdd1a1b32fe450ec82c7c43c078830112e45ef318 (diff)
downloadaports-42ef369b4137842470261877a934b5a10eb53285.tar.bz2
aports-42ef369b4137842470261877a934b5a10eb53285.tar.xz
x11/atk: new aport
A library providing a set of interfaces for accessibility http://www.gtk.org/
Diffstat (limited to 'x11/atk')
-rw-r--r--x11/atk/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11/atk/APKBUILD b/x11/atk/APKBUILD
new file mode 100644
index 00000000..cee5544e
--- /dev/null
+++ b/x11/atk/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=atk
+pkgver=1.24.0
+pkgrel=0
+pkgdesc="A library providing a set of interfaces for accessibility"
+url="http://www.gtk.org/"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="glib libiconv gettext uclibc"
+makedepends="pkgconfig glib-dev gettext-dev libiconv-dev"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/1.24/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-nls \
+ || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="fb0ee9c7f18b15b490a0168b13740a4d atk-1.24.0.tar.bz2"