summaryrefslogtreecommitdiffstats
path: root/x11/dbus
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-31 06:57:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-31 06:57:29 +0000
commit30cd80745024945f8294733c0786780321f76e10 (patch)
tree8f9537f8c5053da4e8156c08d8fc0430ee0adc7a /x11/dbus
parentb82c9254ba0176f35c8ba94c842d3006b6a171dc (diff)
downloadaports-30cd80745024945f8294733c0786780321f76e10.tar.bz2
aports-30cd80745024945f8294733c0786780321f76e10.tar.xz
x11/dbus: new aport
Freedesktop.org message bus system http://www.freedesktop.org/Software/dbus
Diffstat (limited to 'x11/dbus')
-rw-r--r--x11/dbus/APKBUILD38
-rw-r--r--x11/dbus/dbus.initd51
-rw-r--r--x11/dbus/dbus.pre-install4
3 files changed, 93 insertions, 0 deletions
diff --git a/x11/dbus/APKBUILD b/x11/dbus/APKBUILD
new file mode 100644
index 00000000..399b1fe9
--- /dev/null
+++ b/x11/dbus/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dbus
+pkgver=1.2.12
+pkgrel=0
+pkgdesc="Freedesktop.org message bus system"
+url="http://www.freedesktop.org/Software/dbus"
+license="GPL custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="uclibc expat libx11"
+makedepends="expat-dev libx11-dev pkgconfig"
+install="$pkgname.pre-install"
+source="http://$pkgname.freedesktop.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname.initd
+ $install
+ "
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-xml=expat \
+ --with-dbus-user=messagebus \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --disable-verbose-mode \
+ --disable-static \
+ --enable-inotify \
+ --disable-dnotify \
+ --disable-tests \
+ --disable-asserts \
+ --with-x || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ install -Dm755 "$srcdir"/dbus.initd "$pkgdir"/etc/init.d/dbus
+}
+md5sums="39bd582c3b06a261cac44d4cab6fd60b dbus-1.2.12.tar.gz
+58356b4db650a89312a670c02804c540 dbus.initd
+1f3230e131a28409e8769c987b0f624a dbus.pre-install"
diff --git a/x11/dbus/dbus.initd b/x11/dbus/dbus.initd
new file mode 100644
index 00000000..e96ea05c
--- /dev/null
+++ b/x11/dbus/dbus.initd
@@ -0,0 +1,51 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/files/dbus.init-1.0,v 1.4 2007/04/04 13:35:25 cardoe Exp $
+
+opts="reload"
+
+depend() {
+ need localmount
+ after bootmisc
+}
+
+start() {
+ ebegin "Starting D-BUS system messagebus"
+
+ /usr/bin/dbus-uuidgen --ensure
+
+ # We need to test if /var/run/dbus exists, since script will fail if it does not
+ [ ! -e /var/run/dbus ] && mkdir /var/run/dbus
+
+ start-stop-daemon --start --pidfile /var/run/dbus.pid --exec /usr/bin/dbus-daemon -- --system
+ eend $?
+}
+
+stop() {
+ local retval
+
+ ebegin "Stopping D-BUS system messagebus"
+
+ start-stop-daemon --stop --pidfile /var/run/dbus.pid
+ retval=$?
+
+ eend ${retval}
+
+ [ -S /var/run/dbus/system_bus_socket ] && rm -f /var/run/dbus/system_bus_socket
+
+ return ${retval}
+}
+
+reload() {
+ local retval
+
+ ebegin "Reloading D-BUS messagebus config"
+
+ /usr/bin/dbus-send --print-reply --system --type=method_call \
+ --dest=org.freedesktop.DBus \
+ / org.freedesktop.DBus.ReloadConfig > /dev/null
+ retval=$?
+ eend ${retval}
+ return ${retval}
+}
diff --git a/x11/dbus/dbus.pre-install b/x11/dbus/dbus.pre-install
new file mode 100644
index 00000000..515161db
--- /dev/null
+++ b/x11/dbus/dbus.pre-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+adduser -H -h /dev/null -s /bin/false -D messagebus 2>/dev/null
+exit 0