summaryrefslogtreecommitdiffstats
path: root/x11/font-screen-cyrillic
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-03 12:06:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-03 12:06:25 +0000
commit2f8ec833eadb2fe7c99242fc659bb75ebe829d07 (patch)
tree4f6abf3e59997e5f59c9b3e7e2d14aa9c470d9e1 /x11/font-screen-cyrillic
parent1c05e9fc3e2596e912dd7b75054f0961b77bc7b4 (diff)
downloadaports-2f8ec833eadb2fe7c99242fc659bb75ebe829d07.tar.bz2
aports-2f8ec833eadb2fe7c99242fc659bb75ebe829d07.tar.xz
x11/font-*-*: added missing APKBUILDs
Diffstat (limited to 'x11/font-screen-cyrillic')
-rw-r--r--x11/font-screen-cyrillic/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/font-screen-cyrillic/APKBUILD b/x11/font-screen-cyrillic/APKBUILD
new file mode 100644
index 00000000..07965a70
--- /dev/null
+++ b/x11/font-screen-cyrillic/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=font-screen-cyrillic
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="X.org screen cyrillic fonts"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends="encodings font-alias mkfontscale mkfontdir fontconfig"
+makedepends="pkgconfig font-util-dev bdftopcf"
+install="$pkgname.post-install $pkgname.post-upgrade"
+source="http://xorg.freedesktop.org/releases/individual/font/$pkgname-$pkgver.tar.bz2
+ $install"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --with-mapfiles=/usr/share/fonts/util \
+ --with-fontdir=/usr/share/fonts/cyrillic
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" MKFONTDIR=: MKFONTSCALE=: install || return 1
+}
+
+md5sums="c8d5aef01c906c7aaea329702a8b1b63 font-screen-cyrillic-1.0.1.tar.bz2
+e738ad911ff453b7c957007832845f21 font-screen-cyrillic.post-install
+e738ad911ff453b7c957007832845f21 font-screen-cyrillic.post-upgrade"