summaryrefslogtreecommitdiffstats
path: root/x11/gamin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-01 17:53:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-02 11:06:57 +0000
commitc235077afc4d70868137cfdbd0429bf0344cb4ef (patch)
treec71af6463e72d9ea9b5453d4af1eeef5dffe84b9 /x11/gamin
parent31026a9561ba384f1f501cb990238512f8195b4e (diff)
downloadaports-c235077afc4d70868137cfdbd0429bf0344cb4ef.tar.bz2
aports-c235077afc4d70868137cfdbd0429bf0344cb4ef.tar.xz
x11/gamin: new aport
Gamin is a file and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor) system. http://www.gnome.org/~veillard/gamin
Diffstat (limited to 'x11/gamin')
-rw-r--r--x11/gamin/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11/gamin/APKBUILD b/x11/gamin/APKBUILD
new file mode 100644
index 00000000..fe0e5382
--- /dev/null
+++ b/x11/gamin/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gamin
+pkgver=0.1.10
+pkgrel=0
+pkgdesc="Gamin is a file and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor) system."
+url="http://www.gnome.org/~veillard/gamin"
+license="GPL"
+subpackages="$pkgname-dev"
+depends=
+makedepends="pkgconfig glib-dev"
+source="http://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-static \
+ --with-threads \
+ --disable-debug-api \
+ --disable-debug \
+ --disable-server \
+ --disable-fast-install \
+ --disable-dnotify \
+ --libexecdir=/usr/lib/gamin
+ make || return 1
+
+ # some kinde of race in the make install which is not solved with -j
+ export MKDIRPROG="mkdir -p"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="b4ec549e57da470c04edd5ec2876a028 gamin-0.1.10.tar.gz"